summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-27 21:24:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-27 21:24:54 +0000
commit7bdc10dd6788bd7a3497181aff46b4f6c04557aa (patch)
tree6ad7f66f1555371dc7090dcf7678b474261408d1 /sys-freebsd/freebsd-contrib
parentBump to 9.1 (diff)
downloadgentoo-2-7bdc10dd6788bd7a3497181aff46b4f6c04557aa.tar.gz
gentoo-2-7bdc10dd6788bd7a3497181aff46b4f6c04557aa.tar.bz2
gentoo-2-7bdc10dd6788bd7a3497181aff46b4f6c04557aa.zip
Bump to 9.1
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-contrib')
-rw-r--r--sys-freebsd/freebsd-contrib/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-contrib/freebsd-contrib-9.1.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-contrib/ChangeLog b/sys-freebsd/freebsd-contrib/ChangeLog
index 7e0763150946..49c1ff4e64ba 100644
--- a/sys-freebsd/freebsd-contrib/ChangeLog
+++ b/sys-freebsd/freebsd-contrib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-contrib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.40 2013/01/12 10:16:23 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/ChangeLog,v 1.41 2013/01/27 21:24:54 aballier Exp $
+
+*freebsd-contrib-9.1 (27 Jan 2013)
+
+ 27 Jan 2013; Alexis Ballier <aballier@gentoo.org>
+ +freebsd-contrib-9.1.ebuild:
+ Bump to 9.1
12 Jan 2013; Ulrich Müller <ulm@gentoo.org> freebsd-contrib-7.2.ebuild,
freebsd-contrib-8.0.ebuild, freebsd-contrib-8.2.ebuild,
diff --git a/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1.ebuild b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1.ebuild
new file mode 100644
index 000000000000..da525d1a6755
--- /dev/null
+++ b/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-contrib/freebsd-contrib-9.1.ebuild,v 1.1 2013/01/27 21:24:54 aballier Exp $
+
+inherit bsdmk freebsd flag-o-matic multilib
+
+DESCRIPTION="Contributed sources for FreeBSD."
+SRC_URI="mirror://gentoo/${GNU}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD GPL-2+ libodialog"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-sources-${RV}*
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+S="${WORKDIR}/gnu"
+
+src_unpack() {
+ echo ">>> Unpacking needed parts of ${GNU}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${GNU}.tar.bz2" gnu/lib/libodialog gnu/usr.bin/sort gnu/usr.bin/patch
+ echo ">>> Unpacking needed parts of ${CONTRIB}.tar.bz2 to ${WORKDIR}"
+ tar -jxpf "${DISTDIR}/${CONTRIB}.tar.bz2" contrib/gnu-sort
+
+ freebsd_do_patches
+ freebsd_rename_libraries
+}
+
+src_compile() {
+ cd "${S}/lib/libodialog"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/sort"
+ freebsd_src_compile
+
+ cd "${S}/usr.bin/patch"
+ freebsd_src_compile
+}
+
+src_install() {
+ use profile || mymakeopts="${mymakeopts} NO_PROFILE= "
+ mymakeopts="${mymakeopts} NO_MANCOMPRESS= NO_INFOCOMPRESS= "
+
+ cd "${S}/lib/libodialog"
+ mkinstall LIBDIR="/usr/$(get_libdir)" || die "libodialog install failed"
+
+ cd "${S}/usr.bin/sort"
+ mkinstall BINDIR="/bin/" || die "sort install failed"
+
+ cd "${S}/usr.bin/patch"
+ mkinstall BINDIR="/usr/bin/" || die "patch install failed"
+}