summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-09 13:18:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-09 13:18:05 +0000
commit8ed779f0260d7d1361f2037cae9bd50d0ccdf9e8 (patch)
treef3511199a62e0b2c4800ee726712efdc94a2c51b /sys-freebsd/boot0
parentAdd ~x86-fbsd (diff)
downloadgentoo-2-8ed779f0260d7d1361f2037cae9bd50d0ccdf9e8.tar.gz
gentoo-2-8ed779f0260d7d1361f2037cae9bd50d0ccdf9e8.tar.bz2
gentoo-2-8ed779f0260d7d1361f2037cae9bd50d0ccdf9e8.zip
bump to 9.0_rc3
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/boot0')
-rw-r--r--sys-freebsd/boot0/ChangeLog7
-rw-r--r--sys-freebsd/boot0/boot0-9.0_rc3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index 88b5fc926bca..5bf3c0884c0f 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.29 2011/12/07 17:04:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.30 2011/12/09 13:18:05 aballier Exp $
+
+*boot0-9.0_rc3 (09 Dec 2011)
+
+ 09 Dec 2011; Alexis Ballier <aballier@gentoo.org> +boot0-9.0_rc3.ebuild:
+ bump to 9.0_rc3
*boot0-9.0_rc2 (07 Dec 2011)
diff --git a/sys-freebsd/boot0/boot0-9.0_rc3.ebuild b/sys-freebsd/boot0/boot0-9.0_rc3.ebuild
new file mode 100644
index 000000000000..79304ad633a7
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-9.0_rc3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.0_rc3.ebuild,v 1.1 2011/12/09 13:18:05 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-I/usr/include/libstand/"
+ append-flags "-fno-strict-aliasing"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}