summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-06-27 22:08:44 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-06-27 22:08:44 +0000
commit679ac24b982ec3076aa20643623534c91f0228e6 (patch)
treeba2a80924bf4e764dc8420eeb7514cf1df22acbd /sys-firmware
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-679ac24b982ec3076aa20643623534c91f0228e6.tar.gz
gentoo-2-679ac24b982ec3076aa20643623534c91f0228e6.tar.bz2
gentoo-2-679ac24b982ec3076aa20643623534c91f0228e6.zip
Add latest iPXE and add the current version that QEMU uses as well. bug #462898
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/ipxe/ChangeLog10
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130225.ebuild79
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild79
3 files changed, 167 insertions, 1 deletions
diff --git a/sys-firmware/ipxe/ChangeLog b/sys-firmware/ipxe/ChangeLog
index 9a8669a22c62..4e2a38a2cd61 100644
--- a/sys-firmware/ipxe/ChangeLog
+++ b/sys-firmware/ipxe/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-firmware/ipxe
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.5 2013/01/26 20:16:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.6 2013/06/27 22:08:44 cardoe Exp $
+
+*ipxe-1.0.0_p20130225 (27 Jun 2013)
+*ipxe-1.0.0_p20130624 (27 Jun 2013)
+
+ 27 Jun 2013; Doug Goldstein <cardoe@gentoo.org> +ipxe-1.0.0_p20130225.ebuild,
+ +ipxe-1.0.0_p20130624.ebuild:
+ Add latest iPXE and add the current version that QEMU uses as well. bug
+ #462898
26 Jan 2013; Doug Goldstein <cardoe@gentoo.org> ipxe-1.0.0_p20120905.ebuild:
USE=iso needs virtual/cdrtools to successfully build as discovered by Homer
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130225.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130225.ebuild
new file mode 100644
index 000000000000..9a4502e8833f
--- /dev/null
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130225.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130225.ebuild,v 1.1 2013/06/27 22:08:44 cardoe Exp $
+
+EAPI=5
+
+GIT_REV="09c5109b8585178172c7608de8d52e9d9af0b680"
+GIT_SHORT="09c5109"
+
+DESCRIPTION="Open source network boot (PXE) firmware"
+HOMEPAGE="http://ipxe.org"
+SRC_URI="https://git.ipxe.org/ipxe.git/snapshot/${GIT_REV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="iso +qemu undi usb vmware"
+
+DEPEND="sys-devel/make
+ dev-lang/perl
+ sys-libs/zlib
+ iso? (
+ sys-boot/syslinux
+ virtual/cdrtools
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
+
+src_prepare() {
+ cat <<-EOF > "${S}"/config/local/general.h
+#undef BANNER_TIMEOUT
+#define BANNER_TIMEOUT 0
+EOF
+}
+
+src_configure() {
+ if use vmware; then
+ sed -i config/sideband.h \
+ -e 's|//#define[[:space:]]VMWARE_SETTINGS|#define VMWARE_SETTINGS|'
+ sed -i config/console.h \
+ -e 's|//#define[[:space:]]CONSOLE_VMWARE|#define CONSOLE_VMWARE|'
+ fi
+}
+
+src_compile() {
+ if use qemu; then
+ emake bin/808610de.rom # pxe-e1000.rom (old)
+ emake bin/8086100e.rom # pxe-e1000.rom
+ emake bin/80861209.rom # pxe-eepro100.rom
+ emake bin/10500940.rom # pxe-ne2k_pci.rom
+ emake bin/10222000.rom # pxe-pcnet.rom
+ emake bin/10ec8139.rom # pxe-rtl8139.rom
+ emake bin/1af41000.rom # pxe-virtio.rom
+ fi
+
+ if use vmware; then
+ emake bin/8086100f.mrom # e1000
+ emake bin/808610d3.mrom # e1000e
+ emake bin/10222000.mrom # vlance
+ emake bin/15ad07b0.rom # vmxnet3
+ fi
+
+ use iso && emake bin/ipxe.iso
+ use undi && emake bin/undionly.kpxe
+ use usb && emake bin/ipxe.usb
+}
+
+src_install() {
+ insinto /usr/share/ipxe/
+
+ if use qemu || use vmware; then
+ doins bin/*.rom
+ fi
+ use vmware && doins bin/*.mrom
+ use iso && doins bin/*.iso
+ use undi && doins bin/*.kpxe
+ use usb && doins bin/*.usb
+}
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
new file mode 100644
index 000000000000..676317f37588
--- /dev/null
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild,v 1.1 2013/06/27 22:08:44 cardoe Exp $
+
+EAPI=5
+
+GIT_REV="936134ed460618e18cc05d677a442d43d5e739a1"
+GIT_SHORT="936134e"
+
+DESCRIPTION="Open source network boot (PXE) firmware"
+HOMEPAGE="http://ipxe.org"
+SRC_URI="https://git.ipxe.org/ipxe.git/snapshot/${GIT_REV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="iso +qemu undi usb vmware"
+
+DEPEND="sys-devel/make
+ dev-lang/perl
+ sys-libs/zlib
+ iso? (
+ sys-boot/syslinux
+ virtual/cdrtools
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
+
+src_prepare() {
+ cat <<-EOF > "${S}"/config/local/general.h
+#undef BANNER_TIMEOUT
+#define BANNER_TIMEOUT 0
+EOF
+}
+
+src_configure() {
+ if use vmware; then
+ sed -i config/sideband.h \
+ -e 's|//#define[[:space:]]VMWARE_SETTINGS|#define VMWARE_SETTINGS|'
+ sed -i config/console.h \
+ -e 's|//#define[[:space:]]CONSOLE_VMWARE|#define CONSOLE_VMWARE|'
+ fi
+}
+
+src_compile() {
+ if use qemu; then
+ emake bin/808610de.rom # pxe-e1000.rom (old)
+ emake bin/8086100e.rom # pxe-e1000.rom
+ emake bin/80861209.rom # pxe-eepro100.rom
+ emake bin/10500940.rom # pxe-ne2k_pci.rom
+ emake bin/10222000.rom # pxe-pcnet.rom
+ emake bin/10ec8139.rom # pxe-rtl8139.rom
+ emake bin/1af41000.rom # pxe-virtio.rom
+ fi
+
+ if use vmware; then
+ emake bin/8086100f.mrom # e1000
+ emake bin/808610d3.mrom # e1000e
+ emake bin/10222000.mrom # vlance
+ emake bin/15ad07b0.rom # vmxnet3
+ fi
+
+ use iso && emake bin/ipxe.iso
+ use undi && emake bin/undionly.kpxe
+ use usb && emake bin/ipxe.usb
+}
+
+src_install() {
+ insinto /usr/share/ipxe/
+
+ if use qemu || use vmware; then
+ doins bin/*.rom
+ fi
+ use vmware && doins bin/*.mrom
+ use iso && doins bin/*.iso
+ use undi && doins bin/*.kpxe
+ use usb && doins bin/*.usb
+}