summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-30 06:46:45 +0000
committerMark Wright <gienah@gentoo.org>2014-03-30 06:46:45 +0000
commit2339cc524147aad5d2fe6bda09b533db53f5949c (patch)
tree5cfc080e110478a53b29d91bedc8f9ad0411d09c /sys-firmware
parentDrop pypy2_0 support due to lack of its support in pbr, update deps, drop old. (diff)
downloadgentoo-2-2339cc524147aad5d2fe6bda09b533db53f5949c.tar.gz
gentoo-2-2339cc524147aad5d2fe6bda09b533db53f5949c.tar.bz2
gentoo-2-2339cc524147aad5d2fe6bda09b533db53f5949c.zip
Bump iwl3160-ucode to 22.24.8.0 - untested as I do not have access to this hardware.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/iwl3160-ucode/ChangeLog8
-rw-r--r--sys-firmware/iwl3160-ucode/iwl3160-ucode-22.24.8.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-firmware/iwl3160-ucode/ChangeLog b/sys-firmware/iwl3160-ucode/ChangeLog
index 8d74df511c30..09e822e6fa32 100644
--- a/sys-firmware/iwl3160-ucode/ChangeLog
+++ b/sys-firmware/iwl3160-ucode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-firmware/iwl3160-ucode
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl3160-ucode/ChangeLog,v 1.1 2014/01/25 03:35:32 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl3160-ucode/ChangeLog,v 1.2 2014/03/30 06:46:45 gienah Exp $
+
+*iwl3160-ucode-22.24.8.0 (30 Mar 2014)
+
+ 30 Mar 2014; Mark Wright <gienah@gentoo.org> +iwl3160-ucode-22.24.8.0.ebuild:
+ Bump iwl3160-ucode to 22.24.8.0 - untested as I do not have access to this
+ hardware.
*iwl3160-ucode-22.15.8.0 (25 Jan 2014)
*iwl3160-ucode-22.1.7.0 (25 Jan 2014)
diff --git a/sys-firmware/iwl3160-ucode/iwl3160-ucode-22.24.8.0.ebuild b/sys-firmware/iwl3160-ucode/iwl3160-ucode-22.24.8.0.ebuild
new file mode 100644
index 000000000000..f87c60529a74
--- /dev/null
+++ b/sys-firmware/iwl3160-ucode/iwl3160-ucode-22.24.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl3160-ucode/iwl3160-ucode-22.24.8.0.ebuild,v 1.1 2014/03/30 06:46:45 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+DEV_N="${PN:3:4}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=${MY_PN}-${PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 13 0; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.13.0."
+ ewarn "For kernel versions < 3.10.13, you may install older SLOTS"
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-8.ucode"
+ dodoc README*
+}