summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-31 01:56:13 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-31 01:56:13 +0000
commitfc883c453266fbdc8633fac8e26e69fe17d8f812 (patch)
tree622b903bea5e0ba0cbc647fbdd1a9fb0e558a42f /sys-devel
parentmark stable, long overdue (diff)
downloadgentoo-2-fc883c453266fbdc8633fac8e26e69fe17d8f812.tar.gz
gentoo-2-fc883c453266fbdc8633fac8e26e69fe17d8f812.tar.bz2
gentoo-2-fc883c453266fbdc8633fac8e26e69fe17d8f812.zip
Version bump #128557 by Samuli Suominen.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog7
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.153
-rw-r--r--sys-devel/gettext/gettext-0.15.ebuild127
3 files changed, 136 insertions, 1 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index 33f52779c017..b2e08b6b1523 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.111 2006/07/22 15:41:08 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.112 2006/07/31 01:56:13 vapier Exp $
+
+*gettext-0.15 (31 Jul 2006)
+
+ 31 Jul 2006; Mike Frysinger <vapier@gentoo.org> +gettext-0.15.ebuild:
+ Version bump #128557 by Samuli Suominen.
22 Jul 2006; Bryan Østergaard <kloeri@gentoo.org> gettext-0.14.5.ebuild:
Stable on alpha.
diff --git a/sys-devel/gettext/files/digest-gettext-0.15 b/sys-devel/gettext/files/digest-gettext-0.15
new file mode 100644
index 000000000000..ab028c6c56a0
--- /dev/null
+++ b/sys-devel/gettext/files/digest-gettext-0.15
@@ -0,0 +1,3 @@
+MD5 16bc6e4d37ac3d07495f737a2349a22b gettext-0.15.tar.gz 8081941
+RMD160 e485b60965cf74808801e674c570c7ccd63bd61e gettext-0.15.tar.gz 8081941
+SHA256 178100e9375df74e6569e8ac89790b713476204e27283287e2637d07a5760e08 gettext-0.15.tar.gz 8081941
diff --git a/sys-devel/gettext/gettext-0.15.ebuild b/sys-devel/gettext/gettext-0.15.ebuild
new file mode 100644
index 000000000000..59f9b80168ee
--- /dev/null
+++ b/sys-devel/gettext/gettext-0.15.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15.ebuild,v 1.1 2006/07/31 01:56:13 vapier Exp $
+
+inherit flag-o-matic eutils multilib toolchain-funcs mono libtool elisp-common
+
+DESCRIPTION="GNU locale utilities"
+HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls doc nocxx"
+
+DEPEND="virtual/libiconv"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epunt_cxx
+
+ epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
+ # Fix race, bug #85054
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
+
+ # bundled libtool seems to be broken so skip certain rpath tests
+ # http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
+ sed -i \
+ -e '2iexit 77' \
+ autoconf-lib-link/tests/rpath-3*[ef] || die "sed tests"
+
+ # use Gentoo std docdir
+ sed -i \
+ -e "/^docdir=/s:=.*:=/usr/share/doc/${PF}:" \
+ gettext-runtime/configure \
+ gettext-tools/configure \
+ gettext-tools/examples/installpaths.in \
+ || die "sed docdir"
+
+ if use ppc-macos ; then
+ glibtoolize
+ append-flags -bind_at_load
+ fi
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ # Build with --without-included-gettext (on glibc systems)
+ if use elibc_glibc ; then
+ myconf="${myconf} --without-included-gettext $(use_enable nls)"
+ else
+ myconf="${myconf} --with-included-gettext --enable-nls"
+ fi
+ use emacs || export EMACS=no #93823
+ use nocxx && export CXX=$(tc-getCC)
+ econf \
+ --disable-java \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ use nls || rm -r "${D}"/usr/share/locale
+ dosym msgfmt /usr/bin/gmsgfmt #43435
+ dobin gettext-tools/misc/gettextize || die "gettextize"
+
+ # remove stuff that glibc handles
+ if use elibc_glibc ; then
+ rm -f "${D}"/usr/include/libintl.h
+ rm -f "${D}"/usr/$(get_libdir)/libintl.*
+ fi
+ rm -f "${D}"/usr/share/locale/locale.alias "${D}"/usr/lib/charset.alias
+
+ # older gettext's sometimes installed libintl ...
+ # need to keep the linked version or the system
+ # could die (things like sed link against it :/)
+ local libname="libintl$(get_libname 2)"
+ if [[ -e ${ROOT}/usr/$(get_libdir)/${libname} ]] ; then
+ cp -pPR ${ROOT}/usr/$(get_libdir)/${libname}* "${D}"/usr/$(get_libdir)/
+ touch "${D}"/usr/$(get_libdir)/${libname}*
+ fi
+ if ! use elibc_glibc; then
+ # Move dynamic libs and creates ldscripts into /usr/lib
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/${libname}* "${D}"/$(get_libdir)/
+ gen_usr_ldscript libintl$(get_libname)
+ fi
+
+ if ! use doc ; then
+ rm -rf "${D}"/usr/share/doc/${PF}/html
+ rm -rf "${D}"/usr/share/doc/${PF}/{csharpdoc,examples,javadoc2,javadoc1}
+ fi
+ dohtml "${D}"/usr/share/doc/${PF}/*.html
+ rm -f "${D}"/usr/share/doc/${PF}/*.html
+
+ # Remove emacs site-lisp stuff if 'emacs' is not in USE
+ if use emacs ; then
+ elisp-site-file-install "${FILESDIR}"/50po-mode-gentoo.el
+ else
+ rm -rf "${D}"/usr/share/emacs
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ ewarn "Any package that linked against the previous version"
+ ewarn "of gettext will have to be rebuilt."
+ ewarn "Please 'emerge gentoolkit' and run:"
+ ewarn "revdep-rebuild --library libintl.so.2"
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}