summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-14 07:51:12 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-14 07:51:12 +0000
commitfb33d818f5f0ef876c7242c3fb9973103983d16a (patch)
treeab8025556bcfc0fcad7ac5f5c122e03f271d310d /sys-devel
parentremoving obsolete masks (diff)
downloadgentoo-2-fb33d818f5f0ef876c7242c3fb9973103983d16a.tar.gz
gentoo-2-fb33d818f5f0ef876c7242c3fb9973103983d16a.tar.bz2
gentoo-2-fb33d818f5f0ef876c7242c3fb9973103983d16a.zip
Updated sparc64-multilib to use MULTILIB_CHOSTS example.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog6
-rw-r--r--sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild26
2 files changed, 21 insertions, 11 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index b54f439f0de3..c44decc90723 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.174 2004/12/13 01:28:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.175 2004/12/14 07:51:12 eradicator Exp $
+
+ 13 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ binutils-2.15.92.0.2-r1.ebuild:
+ Updated sparc64-multilib to use MULTILIB_CHOSTS example.
*binutils-2.14.90.0.8-r2 (12 Dec 2004)
diff --git a/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild b/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild
index a17e648506e2..0e738cc3a709 100644
--- a/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild,v 1.19 2004/12/12 23:22:37 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.92.0.2-r1.ebuild,v 1.20 2004/12/14 07:51:12 eradicator Exp $
inherit eutils libtool flag-o-matic gnuconfig
@@ -136,15 +136,21 @@ src_install() {
if [ -n "${PROFILE_ARCH}" ]; then
if [ "${PROFILE_ARCH}" = "sparc64-multilib" ]; then
- dodir /usr/${CHOST32}/bin
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/${CHOST32}/bin/${x}
- [ ! -e "${D}/usr/bin/${CHOST32}-${x}" ] && \
- dosym ../${CHOST32}/bin/${x} /usr/bin/${CHOST32}-${x}
+ for CH in ${MULTILIB_CHOSTS}; do
+ if [ "${CH}" = "${CHOST}" ]; then
+ for x in `ls ${D}/usr/${CHOST}/bin/`; do
+ [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
+ dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
+ done
+ else
+ dodir /usr/${CH}/bin
+
+ for x in `ls ${D}/usr/${CHOST}/bin/`; do
+ dosym ../../${CHOST}/bin/${x} /usr/${CH}/bin/${x}
+ [ ! -e "${D}/usr/bin/${CH}-${x}" ] && \
+ dosym ../${CH}/bin/${x} /usr/bin/${CH}-${x}
+ done
+ fi
done
elif [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]; then
dosym ${CHOST} /usr/${CHOST/-/64-}