summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-14 01:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-14 01:56:33 +0000
commitf607a9ea99c1da39f9cd501eefa87726f0ae105b (patch)
treeb6877991002863f66ab87c9d545c2813bf2853c7 /sys-devel
parentbetter cross-compile patch (Manifest recommit) (diff)
downloadgentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.tar.gz
gentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.tar.bz2
gentoo-2-f607a9ea99c1da39f9cd501eefa87726f0ae105b.zip
Use toolchain-funcs to get $CC.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/libperl-5.8.5-r1.ebuild6
-rw-r--r--sys-devel/libperl/libperl-5.8.5.ebuild6
-rw-r--r--sys-devel/libperl/libperl-5.8.6.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 928bce12f8b4..9542acf1221a 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.55 2004/12/07 20:31:35 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.56 2004/12/14 01:56:33 vapier Exp $
+
+ 13 Dec 2004; Mike Frysinger <vapier@gentoo.org> libperl-5.8.5-r1.ebuild,
+ libperl-5.8.5.ebuild, libperl-5.8.6.ebuild:
+ Use toolchain-funcs to get $CC.
07 Dec 2004; Hardave Riar <hardave@gentoo.org> libperl-5.8.5.ebuild:
Stable on mips, dep for bug #66360
diff --git a/sys-devel/libperl/libperl-5.8.5-r1.ebuild b/sys-devel/libperl/libperl-5.8.5-r1.ebuild
index ec3d7fd01ae1..6b3fb81bbb76 100644
--- a/sys-devel/libperl/libperl-5.8.5-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5-r1.ebuild,v 1.3 2004/11/12 15:17:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5-r1.ebuild,v 1.4 2004/12/14 01:56:33 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -54,7 +54,7 @@
IUSE="berkdb debug gdbm ithreads uclibc"
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
# Perl has problems compiling with -Os in your flags
use uclibc || replace-flags "-Os" "-O2"
@@ -199,7 +199,7 @@ src_compile() {
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
-Dccdlflags='-rdynamic' \
- -Dcc="${CC:-gcc}" \
+ -Dcc="$(tc-getCC)" \
-Dprefix='/usr' \
-Dvendorprefix='/usr' \
-Dsiteprefix='/usr' \
diff --git a/sys-devel/libperl/libperl-5.8.5.ebuild b/sys-devel/libperl/libperl-5.8.5.ebuild
index e63f8d127c62..67f39b4deed8 100644
--- a/sys-devel/libperl/libperl-5.8.5.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.11 2004/12/07 20:31:35 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.12 2004/12/14 01:56:33 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -54,7 +54,7 @@
IUSE="berkdb debug gdbm ithreads uclibc"
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
# Perl has problems compiling with -Os in your flags
use uclibc || replace-flags "-Os" "-O2"
@@ -197,7 +197,7 @@ src_compile() {
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
-Dccdlflags='-rdynamic' \
- -Dcc="${CC:-gcc}" \
+ -Dcc="$(tc-getCC)" \
-Dprefix='/usr' \
-Dvendorprefix='/usr' \
-Dsiteprefix='/usr' \
diff --git a/sys-devel/libperl/libperl-5.8.6.ebuild b/sys-devel/libperl/libperl-5.8.6.ebuild
index b490fb81ca16..a87e1dff3947 100644
--- a/sys-devel/libperl/libperl-5.8.6.ebuild
+++ b/sys-devel/libperl/libperl-5.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.1 2004/11/30 21:01:58 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.2 2004/12/14 01:56:33 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -54,7 +54,7 @@
IUSE="berkdb debug gdbm ithreads uclibc"
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
# Perl has problems compiling with -Os in your flags
use uclibc || replace-flags "-Os" "-O2"
@@ -196,7 +196,7 @@ src_compile() {
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
-Dccdlflags='-rdynamic' \
- -Dcc="${CC:-gcc}" \
+ -Dcc="$(tc-getCC)" \
-Dprefix='/usr' \
-Dvendorprefix='/usr' \
-Dsiteprefix='/usr' \