summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-04-24 23:53:52 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-04-24 23:53:52 +0000
commitf4ef805c12a55551f4bc83635e8f2731833fe87d (patch)
tree80e747284126da597f4f4f815a06ab2b76f22597 /sys-devel
parentAdd in lto use flag, and cleaning up of python scripts for gcc-4.5 (diff)
downloadgentoo-2-f4ef805c12a55551f4bc83635e8f2731833fe87d.tar.gz
gentoo-2-f4ef805c12a55551f4bc83635e8f2731833fe87d.tar.bz2
gentoo-2-f4ef805c12a55551f4bc83635e8f2731833fe87d.zip
Version bump to 4.5.0; fixes bug #315377. Thanks to Ryan Hill <dirtyepic AT gentoo DOT org> for help figuring out the changes needed
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog9
-rw-r--r--sys-devel/gcc/gcc-4.5.0.ebuild92
-rw-r--r--sys-devel/gcc/metadata.xml1
3 files changed, 101 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index fad93de31708..0fcc6d835275 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.747 2010/04/24 18:19:00 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.748 2010/04/24 23:53:52 halcy0n Exp $
+
+*gcc-4.5.0 (24 Apr 2010)
+
+ 24 Apr 2010; Mark Loeser <halcy0n@gentoo.org> +gcc-4.5.0.ebuild,
+ metadata.xml:
+ Version bump to 4.5.0; fixes bug #315377. Thanks to Ryan Hill <dirtyepic
+ AT gentoo DOT org> for help figuring out the changes needed
24 Apr 2010; Mark Loeser <halcy0n@gentoo.org> gcc-4.4.3.ebuild:
Add ewarn about the use of graphite
diff --git a/sys-devel/gcc/gcc-4.5.0.ebuild b/sys-devel/gcc/gcc-4.5.0.ebuild
new file mode 100644
index 000000000000..148c3808ba93
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.5.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.0.ebuild,v 1.1 2010/04/24 23:53:52 halcy0n Exp $
+
+GENTOO_PATCH_EXCLUDE="00_all_gcc-trampolinewarn.patch
+18_all_904-flatten-switch-stmt-00.patch
+54_all_300-libstdc++-pic.patch
+73_all_sh-libgcc-stacks.patch
+90_all_gcc-freebsd.patch
+91_all_gcc-freebsd.patch"
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# Hardened gcc 4 stuff
+#PIE_VER="10.1.5"
+#SPECS_VER="0.9.4"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+#PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
+#PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+KEYWORDS=""
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ graphite? (
+ >=dev-libs/ppl-0.10
+ >=dev-libs/cloog-ppl-0.15.8
+ )
+ lto? ( >=dev-libs/elfutils-0.143 )
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/dejagnu-1.4.4 >=sys-devel/autogen-5.5.4 )
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
+}
+
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index 251dfa3ca223..b4f808f8daed 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -13,6 +13,7 @@
<flag name="ip32r10k">Enable building a compiler capable of building an
experimental kernel for SGI O2 w/ R1x000 CPUs (IP32)</flag>
<flag name="libffi">Build the portable foreign function interface library</flag>
+ <flag name="lto">Add support for link-time optimizations</flag>
<flag name="mudflap">Add support for mudflap, a pointer use checking library</flag>
<flag name="multislot">Allow for SLOTs to include minor version (3.3.4
instead of just 3.3)</flag>