summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-09-24 18:50:27 +0000
committerFabian Groffen <grobian@gentoo.org>2009-09-24 18:50:27 +0000
commited509cc4632662db83fe492dd95ae3e12d88b56e (patch)
tree22e5368740338a078f8f3ae2e378aecc9e5bf3ed /sys-devel
parentarm stable (diff)
downloadgentoo-2-ed509cc4632662db83fe492dd95ae3e12d88b56e.tar.gz
gentoo-2-ed509cc4632662db83fe492dd95ae3e12d88b56e.tar.bz2
gentoo-2-ed509cc4632662db83fe492dd95ae3e12d88b56e.zip
Bump to version from Xcode Developer Tools 3.2, thanks Heiko Przybyl in bug #286285
(Portage version: 2.2.00.14411-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog8
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1344.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index 6195024c0b33..15923d074057 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.2 2009/06/24 09:40:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.3 2009/09/24 18:50:27 grobian Exp $
+
+*gdb-apple-1344 (24 Sep 2009)
+
+ 24 Sep 2009; Fabian Groffen <grobian@gentoo.org> +gdb-apple-1344.ebuild:
+ Bump to version from Xcode Developer Tools 3.2, thanks Heiko Przybyl in
+ bug #286285
24 Jun 2009; Fabian Groffen <grobian@gentoo.org>
+files/gdb-apple-962-darwin64.patch, +files/gdb-apple-962-demangle.patch,
diff --git a/sys-devel/gdb-apple/gdb-apple-1344.ebuild b/sys-devel/gdb-apple/gdb-apple-1344.ebuild
new file mode 100644
index 000000000000..e3d716d31b19
--- /dev/null
+++ b/sys-devel/gdb-apple/gdb-apple-1344.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-1344.ebuild,v 1.1 2009/09/24 18:50:27 grobian Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Apple branch of the GNU Debugger, Developer Tools 3.2"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
+
+LICENSE="APSL-2 GPL-2"
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ =dev-db/sqlite-3*"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/gdb-${PV}/src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-768-texinfo.patch
+
+ # for FSF gcc / gcc-apple:42
+ sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
+}
+
+src_compile() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_install() {
+ local ED=${ED-${D}}
+
+ emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
+ rm -R "${D}"/nukeme || die
+ rm -Rf "${ED}"/usr/${CHOST} || die
+ mv "${ED}"/usr/bin/gdb ${ED}/
+ rm -f "${ED}"/usr/bin/*
+ mv "${ED}"/gdb "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
+ ewarn "Due to increased security measures in 10.5 and up, gdb is"
+ ewarn "not able to get a mach task port when installed by Prefix"
+ ewarn "Portage, unprivileged. To make gdb fully functional you'll"
+ ewarn "have to perform the following steps:"
+ ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ fi
+}