summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-12-30 00:58:40 +0000
committerMike Frysinger <vapier@gentoo.org>2006-12-30 00:58:40 +0000
commiteb8afe98c1749ccab30e30983a4b05ad06271e8e (patch)
treedb9b47fc9c737fbef04867277ebda3d5edbf3da8 /sys-devel
parentMasking dev-python/snmpy for removal (diff)
downloadgentoo-2-eb8afe98c1749ccab30e30983a4b05ad06271e8e.tar.gz
gentoo-2-eb8afe98c1749ccab30e30983a4b05ad06271e8e.tar.bz2
gentoo-2-eb8afe98c1749ccab30e30983a4b05ad06271e8e.zip
document patches
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/files/gettext-0.14.2-fix-race.patch6
-rw-r--r--sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch9
-rw-r--r--sys-devel/gettext/gettext-0.15-r1.ebuild7
-rw-r--r--sys-devel/gettext/gettext-0.15.ebuild5
4 files changed, 16 insertions, 11 deletions
diff --git a/sys-devel/gettext/files/gettext-0.14.2-fix-race.patch b/sys-devel/gettext/files/gettext-0.14.2-fix-race.patch
index dd0bf96abc94..57d381d37ca7 100644
--- a/sys-devel/gettext/files/gettext-0.14.2-fix-race.patch
+++ b/sys-devel/gettext/files/gettext-0.14.2-fix-race.patch
@@ -1,5 +1,7 @@
---- gettext-0.14.2/gettext-tools/misc/Makefile.in.az 2005-03-14 00:40:56.000000000 +0200
-+++ gettext-0.14.2/gettext-tools/misc/Makefile.in 2005-03-14 00:41:26.000000000 +0200
+http://bugs.gentoo.org/85054
+
+--- gettext-0.14.2/gettext-tools/misc/Makefile.in
++++ gettext-0.14.2/gettext-tools/misc/Makefile.in
@@ -441,7 +441,7 @@
shift; \
EMACS="$(EMACS)" $(SHELL) $(elisp_comp) "$$@" || exit 1; \
diff --git a/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch b/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch
index d2088978eca5..4630d1dd92d3 100644
--- a/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch
+++ b/sys-devel/gettext/files/gettext-0.15-expat-no-dlopen.patch
@@ -1,5 +1,10 @@
---- gettext-0.15/gettext-tools/configure.orig 2006-07-21 15:38:28.000000000 +0200
-+++ gettext-0.15/gettext-tools/configure 2006-10-07 01:19:15.295758370 +0200
+Add support for expat-2 to xgettext by linking it at build time rather than
+at runtime using dlopen
+
+http://bugs.gentoo.org/146211
+
+--- gettext-0.15/gettext-tools/configure
++++ gettext-0.15/gettext-tools/configure
@@ -44267,19 +44266,6 @@
diff --git a/sys-devel/gettext/gettext-0.15-r1.ebuild b/sys-devel/gettext/gettext-0.15-r1.ebuild
index b47b84e423db..eb2f7d6f65d7 100644
--- a/sys-devel/gettext/gettext-0.15-r1.ebuild
+++ b/sys-devel/gettext/gettext-0.15-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15-r1.ebuild,v 1.3 2006/12/28 20:45:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15-r1.ebuild,v 1.4 2006/12/30 00:58:40 vapier Exp $
inherit flag-o-matic eutils multilib toolchain-funcs mono libtool elisp-common
@@ -23,9 +23,8 @@ src_unpack() {
epunt_cxx
epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
- # Fix race, bug #85054
- epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
- epatch "${FILESDIR}"/${P}-expat-no-dlopen.patch
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch #85054
+ epatch "${FILESDIR}"/${PN}-0.15-expat-no-dlopen.patch #146211
# bundled libtool seems to be broken so skip certain rpath tests
# http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html
diff --git a/sys-devel/gettext/gettext-0.15.ebuild b/sys-devel/gettext/gettext-0.15.ebuild
index abe0957409e0..cb89105212ae 100644
--- a/sys-devel/gettext/gettext-0.15.ebuild
+++ b/sys-devel/gettext/gettext-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15.ebuild,v 1.18 2006/12/29 22:10:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.15.ebuild,v 1.19 2006/12/30 00:58:40 vapier Exp $
inherit flag-o-matic eutils multilib toolchain-funcs mono libtool elisp-common
@@ -22,8 +22,7 @@ src_unpack() {
epunt_cxx
epatch "${FILESDIR}"/${PN}-0.14.1-lib-path-tests.patch #81628
- # Fix race, bug #85054
- epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch
+ epatch "${FILESDIR}"/${PN}-0.14.2-fix-race.patch #85054
# bundled libtool seems to be broken so skip certain rpath tests
# http://lists.gnu.org/archive/html/bug-libtool/2005-03/msg00070.html