summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-16 19:53:08 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-16 19:53:08 +0000
commiteb085eae36fd4ff68712dbe53987571c1711e820 (patch)
tree710b3a4c446ba69ad4b64c57e0e2ad99571f8ac5 /sys-devel
parentChange test in pkg_setup to account for app-emacs/gnus cvs snapshots. (diff)
downloadgentoo-2-eb085eae36fd4ff68712dbe53987571c1711e820.tar.gz
gentoo-2-eb085eae36fd4ff68712dbe53987571c1711e820.tar.bz2
gentoo-2-eb085eae36fd4ff68712dbe53987571c1711e820.zip
Version bump.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog7
-rw-r--r--sys-devel/libtool/libtool-2.2.6b.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 6fff9d3ea581..897e600923d8 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.158 2009/10/13 17:25:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.159 2009/11/16 19:53:08 vapier Exp $
+
+*libtool-2.2.6b (16 Nov 2009)
+
+ 16 Nov 2009; Mike Frysinger <vapier@gentoo.org> +libtool-2.2.6b.ebuild:
+ Version bump.
13 Oct 2009; Raúl Porcel <armin76@gentoo.org> libtool-2.2.6a.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #257399
diff --git a/sys-devel/libtool/libtool-2.2.6b.ebuild b/sys-devel/libtool/libtool-2.2.6b.ebuild
new file mode 100644
index 000000000000..a66847ecf3fa
--- /dev/null
+++ b/sys-devel/libtool/libtool-2.2.6b.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.6b.ebuild,v 1.1 2009/11/16 19:53:08 vapier Exp $
+
+LIBTOOLIZE="true" #225559
+inherit eutils autotools flag-o-matic multilib
+
+DESCRIPTION="A shared library tool for developers"
+HOMEPAGE="http://www.gnu.org/software/libtool/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="1.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="vanilla test"
+
+RDEPEND="sys-devel/gnuconfig
+ >=sys-devel/autoconf-2.60
+ >=sys-devel/automake-1.10.1"
+DEPEND="${RDEPEND}
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ sys-apps/help2man"
+
+pkg_setup() {
+ if use test && ! has_version '>sys-devel/binutils-2.19.51'; then
+ einfo "Disabling --as-needed, since you got older binutils and you asked"
+ einfo "to run tests. With the stricter (older) --as-needed behaviour"
+ einfo "you'd be seeing a test failure in test #63; this has been fixed"
+ einfo "in the newer version of binutils."
+ append-ldflags $(no-as-needed)
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/2.2.6a/${PN}-2.2.6a-tests-locale.patch #249168
+
+ if ! use vanilla ; then
+ epunt_cxx
+ cd libltdl/m4
+ epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ cd ..
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ fi
+
+ # the libtool script uses bash code in it and at configure time, tries
+ # to find a bash shell. if /bin/sh is bash, it uses that. this can
+ # cause problems for people who switch /bin/sh on the fly to other
+ # shells, so just force libtool to use /bin/bash all the time.
+ export CONFIG_SHELL=/bin/bash
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
+
+ local x
+ for x in libtool libtoolize ; do
+ help2man ${x} > ${x}.1
+ doman ${x}.1 || die
+ done
+
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
+ done
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
+}