summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-17 13:04:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-17 13:04:03 +0000
commite10ae7d258650fbe04849cb64ccc55a6a4347dde (patch)
treeff5e1cedbd749fc5ccc5ced8bf8a4f8b4d790d92 /sys-devel
parentppc stable #245707 (diff)
downloadgentoo-2-e10ae7d258650fbe04849cb64ccc55a6a4347dde.tar.gz
gentoo-2-e10ae7d258650fbe04849cb64ccc55a6a4347dde.tar.bz2
gentoo-2-e10ae7d258650fbe04849cb64ccc55a6a4347dde.zip
Replace the 1.10b ebuild with the same source installed as 1.11_beta, with 1.11 slot and fixed dependencies. This version is masked, but can now be used on the same system as 1.10 without extra hassle.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog10
-rw-r--r--sys-devel/automake/automake-1.11_beta.ebuild (renamed from sys-devel/automake/automake-1.10b.ebuild)50
2 files changed, 41 insertions, 19 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 6b186a9783af..d381c7b408ee 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.135 2009/04/17 20:32:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.136 2009/05/17 13:04:03 flameeyes Exp $
+
+*automake-1.11_beta (17 May 2009)
+
+ 17 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ -automake-1.10b.ebuild, +automake-1.11_beta.ebuild:
+ Replace the 1.10b ebuild with the same source installed as 1.11_beta, with
+ 1.11 slot and fixed dependencies. This version is masked, but can now be
+ used on the same system as 1.10 without extra hassle.
17 Apr 2009; Zac Medico <zmedico@gentoo.org> automake-1.10b.ebuild:
Fix SRC_URI since alpha/beta releases are not distributed on the usual
diff --git a/sys-devel/automake/automake-1.10b.ebuild b/sys-devel/automake/automake-1.11_beta.ebuild
index 945b53307d53..15d748e3b362 100644
--- a/sys-devel/automake/automake-1.10b.ebuild
+++ b/sys-devel/automake/automake-1.11_beta.ebuild
@@ -1,23 +1,35 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.10b.ebuild,v 1.2 2009/04/17 20:32:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.11_beta.ebuild,v 1.1 2009/05/17 13:04:03 flameeyes Exp $
-inherit eutils
+inherit eutils versionator
+
+if [[ ${PV/_beta} == ${PV} ]]; then
+ MY_P=${P}
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+else
+ MY_PV="$(get_major_version).$(($(get_version_component_range 2)-1))b"
+ MY_P="${PN}-${MY_PV}"
+
+ # Alpha/beta releases are not distributed on the usual mirrors.
+ SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${MY_P}.tar.bz2"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+# Use Gentoo versioning for slotting.
+SLOT="${PV:0:4}"
DESCRIPTION="Used to generate Makefile.in from Makefile.am"
HOMEPAGE="http://sources.redhat.com/automake/"
-# Alpha/beta releases are not distributed on the usual mirrors.
-#SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
-SRC_URI="ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
-SLOT="${PV:0:4}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
- >=sys-devel/automake-wrapper-2
- >=sys-devel/autoconf-2.60
+ >=sys-devel/automake-wrapper-3-r2
+ >=sys-devel/autoconf-2.62
>=sys-apps/texinfo-4.7
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
@@ -39,24 +51,26 @@ src_unpack() {
}
src_compile() {
- econf --docdir=/usr/share/doc/${PF} || die
- emake || die
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
+ emake \
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+
+ local x
+ for x in aclocal automake; do
+ help2man "perl -Ilib ${x}" > doc/${x}-${SLOT}.1
+ done
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install \
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
- # SLOT the docs and junk
- local x
- for x in aclocal automake ; do
- help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
- doman ${x}-${SLOT}.1
- rm -f "${D}"/usr/bin/${x}
- done
+ rm "${D}"/usr/bin/{aclocal,automake}
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
+ local x
for x in guess sub ; do
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done