summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-25 20:27:26 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-25 20:27:26 +0000
commitd9453abbcb1c31c850b086542c1d4211ee979efe (patch)
tree33bbd868fd2b730b12945aec4edd0c91d833e173 /sys-devel
parentresolve bug #1880 (diff)
downloadgentoo-2-d9453abbcb1c31c850b086542c1d4211ee979efe.tar.gz
gentoo-2-d9453abbcb1c31c850b086542c1d4211ee979efe.tar.bz2
gentoo-2-d9453abbcb1c31c850b086542c1d4211ee979efe.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog4
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.1.ebuild123
-rw-r--r--sys-devel/binutils/binutils-2.12.90.0.7.ebuild (renamed from sys-devel/binutils/binutils-2.12.90.0.3.ebuild)2
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.11
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.31
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.12.90.0.71
6 files changed, 5 insertions, 127 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index 39eeae32e257..9aaa988887b2 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.5 2002/04/15 23:30:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.6 2002/04/25 20:27:26 azarah Exp $
+
+*binutils-2.12.90.0.7 (25 Apr 2002)
*binutils-2.12.90.0.4 (16 Apr 2002)
diff --git a/sys-devel/binutils/binutils-2.12.90.0.1.ebuild b/sys-devel/binutils/binutils-2.12.90.0.1.ebuild
deleted file mode 100644
index 4a92882f49a8..000000000000
--- a/sys-devel/binutils/binutils-2.12.90.0.1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: System Team <system@gentoo.org>
-# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.1.ebuild,v 1.4 2002/04/03 00:43:47 azarah Exp $
-
-# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
-# the manpages, but seems this is incorrect ....
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
-
-DEPEND="virtual/glibc
- nls? ( sys-devel/gettext )"
-
-[ -z "`use build`" ] && [ -z "`use bootstrap`" ] && DEPEND="${DEPEND} sys-devel/perl"
-
-
-src_compile() {
-
- local myconf=""
- use nls && \
- myconf="${myconf} --without-included-gettext" || \
- myconf="${myconf} --disable-nls"
-
- # DO NOT LIBTOOLIZE, AS BINUTILS COME WITH ITS OWN VERSION
- # OF LIBTOOL!!!!!!!
- libtoolize --copy --force
-
- ./configure --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} || die
-
- if [ "`use static`" ]
- then
- make headers -C bfd CFLAGS=-O || die
- emake -e LDFLAGS=-all-static || die
- else
- make headers -C bfd CFLAGS=-O || die
- emake || die
- fi
-
- if [ -z "`use build`" ]
- then
- if [ -z "`use bootstrap`" ]
- then
- #nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm {} ';'
- fi
- #make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- #c++filt is included with gcc -- what are these GNU people thinking?
- #but not the manpage, so leave that!
- rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- #strip has a symlink going from /usr/${CHOST}/bin/strip to /usr/bin/strip
- #we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- #the strip symlink gets created in the loop below
-
- #ar, as, ld, nm, ranlib and strip are in two places; create symlinks. This will reduce the
- #size of the tbz2 significantly. We also move all the stuff in /usr/bin to /usr/${CHOST}/bin
- #and create the appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv $x ../${CHOST}/bin/${x}
- else
- rm -f $x
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- cd ${S}
- if [ -z "`use build`" ]
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- #install pre-generated manpages
- else
- rm -rf ${D}/usr/share/man
- fi
-}
-
diff --git a/sys-devel/binutils/binutils-2.12.90.0.3.ebuild b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
index a12e0fd58b6a..25421e48365f 100644
--- a/sys-devel/binutils/binutils-2.12.90.0.3.ebuild
+++ b/sys-devel/binutils/binutils-2.12.90.0.7.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: System Team <system@gentoo.org>
# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.3.ebuild,v 1.1 2002/04/07 07:05:49 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.12.90.0.7.ebuild,v 1.1 2002/04/25 20:27:26 azarah Exp $
# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
# the manpages, but seems this is incorrect ....
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.1 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.1
deleted file mode 100644
index 3d2a8e73042c..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.12.90.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 426c30debcb338cb2dcad2f7ec7e61e7 binutils-2.12.90.0.1.tar.bz2 8716103
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.3 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.3
deleted file mode 100644
index c59246e89bf9..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.12.90.0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f6c42e6d89785198dea45d97a609b349 binutils-2.12.90.0.3.tar.bz2 8741219
diff --git a/sys-devel/binutils/files/digest-binutils-2.12.90.0.7 b/sys-devel/binutils/files/digest-binutils-2.12.90.0.7
new file mode 100644
index 000000000000..f4e65969449b
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.12.90.0.7
@@ -0,0 +1 @@
+MD5 bebbe8a8795a71afce58bb1fc1e3b894 binutils-2.12.90.0.7.tar.bz2 8733848