summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-29 20:42:45 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-29 20:42:45 +0000
commitd1212a8fc4a26e34cea1d5186260de916b50be5c (patch)
tree830415c6d761b1810f0d99a3155f5a8d575ea254 /sys-devel
parentold (diff)
downloadgentoo-2-d1212a8fc4a26e34cea1d5186260de916b50be5c.tar.gz
gentoo-2-d1212a8fc4a26e34cea1d5186260de916b50be5c.tar.bz2
gentoo-2-d1212a8fc4a26e34cea1d5186260de916b50be5c.zip
Version bump.
(Portage version: 2.1.3.16)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/ChangeLog7
-rw-r--r--sys-devel/gdb/files/digest-gdb-6.7.16
-rw-r--r--sys-devel/gdb/gdb-6.7.1.ebuild82
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index d05a6634eacc..80f7b8170567 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.121 2007/10/10 20:14:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.122 2007/10/29 20:42:44 vapier Exp $
+
+*gdb-6.7.1 (29 Oct 2007)
+
+ 29 Oct 2007; Mike Frysinger <vapier@gentoo.org> +gdb-6.7.1.ebuild:
+ Version bump.
*gdb-6.7 (10 Oct 2007)
diff --git a/sys-devel/gdb/files/digest-gdb-6.7.1 b/sys-devel/gdb/files/digest-gdb-6.7.1
new file mode 100644
index 000000000000..c15b0636afa9
--- /dev/null
+++ b/sys-devel/gdb/files/digest-gdb-6.7.1
@@ -0,0 +1,6 @@
+MD5 1a62a6d8fd77cab88dce2a6a8e0d66b3 gdb-6.7.1-patches-1.0.tar.bz2 12966
+RMD160 6a71494624e4b48a50e735c41fc2575ac8ec320d gdb-6.7.1-patches-1.0.tar.bz2 12966
+SHA256 641c0a6d18521ef05eaee0bf2c95889c330504e9cb8e01a68223ff800aa5e003 gdb-6.7.1-patches-1.0.tar.bz2 12966
+MD5 30a6bf36eded4ae5a152d7d71b86dc14 gdb-6.7.1.tar.bz2 15080950
+RMD160 c5ae709aefe75094c8d08341bfb882b490ddb2a2 gdb-6.7.1.tar.bz2 15080950
+SHA256 f98cec38420f4f1ce3da2f16e6045f086d24dfcf05996b2d74f8620691442f62 gdb-6.7.1.tar.bz2 15080950
diff --git a/sys-devel/gdb/gdb-6.7.1.ebuild b/sys-devel/gdb/gdb-6.7.1.ebuild
new file mode 100644
index 000000000000..6330b4a98748
--- /dev/null
+++ b/sys-devel/gdb/gdb-6.7.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.7.1.ebuild,v 1.1 2007/10/29 20:42:44 vapier Exp $
+
+inherit flag-o-matic eutils
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+PATCH_VER="1.0"
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
+ ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls test vanilla"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ strip-linguas -u bfd/po opcodes/po
+}
+
+src_compile() {
+ replace-flags -O? -O2
+ econf \
+ --disable-werror \
+ $(use_enable nls) \
+ || die
+ emake || die
+}
+
+src_test() {
+ make check || ewarn "tests failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
+ install || die
+ rm -r "${D}"/nukeme || die
+
+ # Don't install docs when building a cross-gdb
+ if [[ ${CTARGET} != ${CHOST} ]] ; then
+ rm -r "${D}"/usr/share
+ return 0
+ fi
+
+ dodoc README
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
+ gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ dodoc "${WORKDIR}"/extra/gdbinit.sample
+
+ # Remove shared info pages
+ rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+}
+
+pkg_postinst() {
+ # portage sucks and doesnt unmerge files in /etc
+ rm -vf "${ROOT}"/etc/skel/.gdbinit
+}