summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-05 03:05:42 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-05 03:05:42 +0000
commitc6a73a801701b450582ec990708319532b9359a4 (patch)
tree9aba6a3cee0bbc9dc638dad9e91fbd2dbc3a02e4 /sys-devel
parentfix timezone-data DEPEND for cross builds (diff)
downloadgentoo-2-c6a73a801701b450582ec990708319532b9359a4.tar.gz
gentoo-2-c6a73a801701b450582ec990708319532b9359a4.tar.bz2
gentoo-2-c6a73a801701b450582ec990708319532b9359a4.zip
Fix changing of profiles when using ROOT and a different CHOST.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog11
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r4)0
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.128
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.1310
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild)4
5 files changed, 26 insertions, 7 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 313c079b8819..0a398c99f587 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc-config
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.113 2005/12/30 11:04:41 vapier Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.114 2006/01/05 03:05:42 vapier Exp $
+
+*gcc-config-1.3.12-r5 (05 Jan 2006)
+
+ 05 Jan 2006; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.12,
+ files/gcc-config-1.3.13, -gcc-config-1.3.12-r4.ebuild,
+ +gcc-config-1.3.12-r5.ebuild:
+ Fix changing of profiles when using ROOT and a different CHOST.
*gcc-config-1.3.13 (30 Dec 2005)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r4 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r4
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index c0de03df30c2..8366a2678f7c 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.12 2005/12/27 02:45:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.13 2006/01/05 03:05:42 vapier Exp $
trap ":" INT QUIT TSTP
@@ -102,6 +102,12 @@ cheap_portageq_envvar() {
get_real_chost() {
[[ -n ${REAL_CHOST} ]] && return 0
+ # shortcut for switching compilers in a cross chroot
+ if [[ -n ${CHOST} && ${ROOT} != "/" ]] ; then
+ REAL_CHOST=${CHOST}
+ return 0
+ fi
+
# make sure portage isnt broken
if ${PYTHON} -V &>/dev/null ; then
export REAL_CHOST=$(${ENV} -i ${PORTAGEQ} envvar CHOST 2>/dev/null)
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.13 b/sys-devel/gcc-config/files/gcc-config-1.3.13
index 741b3853bbf1..2a82308a947b 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.13
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.13
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.1 2005/12/30 11:04:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.2 2006/01/05 03:05:42 vapier Exp $
trap ":" INT QUIT TSTP
@@ -102,6 +102,12 @@ cheap_portageq_envvar() {
get_real_chost() {
[[ -n ${REAL_CHOST} ]] && return 0
+ # shortcut for switching compilers in a cross chroot
+ if [[ -n ${CHOST} && ${ROOT} != "/" ]] ; then
+ REAL_CHOST=${CHOST}
+ return 0
+ fi
+
# make sure portage isnt broken
if ${PYTHON} -V &>/dev/null ; then
export REAL_CHOST=$(${ENV} -i ${PORTAGEQ} envvar CHOST 2>/dev/null)
@@ -272,7 +278,7 @@ switch_profile() {
# http://bugs.gentoo.org/60190
#
# The funky move magic is required for proper updating of in-use files.
- if ! is_cross_compiler ; then
+ if ! is_cross_compiler && [[ ${ROOT} == "/" ]] ; then
# Need to cut out extra paths in multilib case and pray the first path
# is the "root" multilib path ... maybe some day change this to use
# `gcc -print-file-name` ...
diff --git a/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild
index 4e07d66b7bb9..a04e9726b036 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r4.ebuild,v 1.2 2005/12/27 02:45:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild,v 1.1 2006/01/05 03:05:42 vapier Exp $
inherit toolchain-funcs multilib