summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-23 00:37:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-23 00:37:41 +0000
commitc57ba07468be02147002193afc2b2124a2cd8c83 (patch)
tree0f8a3582a895d3f24703d57de957504b5e431cc0 /sys-devel
parentinstall man page and a few other important docs (diff)
downloadgentoo-2-c57ba07468be02147002193afc2b2124a2cd8c83.tar.gz
gentoo-2-c57ba07468be02147002193afc2b2124a2cd8c83.tar.bz2
gentoo-2-c57ba07468be02147002193afc2b2124a2cd8c83.zip
freebsd patch is too intrusive atm for non-freebsd targets
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.15.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-devel/binutils/binutils-2.15.ebuild b/sys-devel/binutils/binutils-2.15.ebuild
index eaa3f6eae599..f1f81fb49f34 100644
--- a/sys-devel/binutils/binutils-2.15.ebuild
+++ b/sys-devel/binutils/binutils-2.15.ebuild
@@ -1,9 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.ebuild,v 1.5 2005/05/20 04:15:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.ebuild,v 1.6 2005/05/23 00:37:41 vapier Exp $
PATCHVER="1.1"
UCLIBC_PATCHVER=""
inherit toolchain-binutils
KEYWORDS="-*"
+
+src_unpack() {
+ tc-binutils_unpack
+
+ cd "${WORKDIR}"/patch
+ # FreeBSD patches are not safe
+ [[ ${CTARGET} != *-freebsd* ]] && mv 00_all_freebsd* skip/
+
+ tc-binutils_apply_patches
+}