summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-07-19 22:51:23 +0000
committerTravis Tilley <lv@gentoo.org>2004-07-19 22:51:23 +0000
commitc3f67a3599449202717e40beb8ab55653ecc5a8b (patch)
tree03de4bf07f5b782ad37c3f8e27bfd5d4c88f1438 /sys-devel
parent~amd64 ~sparc (Manifest recommit) (diff)
downloadgentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.tar.gz
gentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.tar.bz2
gentoo-2-c3f67a3599449202717e40beb8ab55653ecc5a8b.zip
changed use of gtk2 USE flag to gtk
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/gcc-3.4.0-r6.ebuild8
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-3.4.1.ebuild8
4 files changed, 17 insertions, 13 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 132ece5320ca..880576ec438b 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.287 2004/07/14 18:34:15 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.288 2004/07/19 22:51:23 lv Exp $
+
+ 19 Jul 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0-r6.ebuild,
+ gcc-3.4.1-r1.ebuild, gcc-3.4.1.ebuild:
+ changed use of gtk2 USE flag to gtk
14 Jul 2004; <solar@gentoo.org> gcc-3.3.4-r1.ebuild:
gcc-3.3.4-r1 marked -hppa ~x86 ~amd64 ~mips ~arm, ~sparc desired
diff --git a/sys-devel/gcc/gcc-3.4.0-r6.ebuild b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
index 2affe134becc..44d4ea9a5e46 100644
--- a/sys-devel/gcc/gcc-3.4.0-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0-r6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.19 2004/07/14 23:28:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r6.ebuild,v 1.20 2004/07/19 22:51:23 lv Exp $
-IUSE="static nls bootstrap build multilib gcj gtk2 f77 objc hardened uclibc n32 n64"
+IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
inherit eutils flag-o-matic libtool gnuconfig
@@ -166,7 +166,7 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
>=sys-devel/gcc-config-1.3.1
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
- !ppc64? ( !build? ( gcj? ( gtk2? ( >=x11-libs/gtk+-2.2 ) ) ) )
+ !ppc64? ( !build? ( gcj? ( gtk? ( >=x11-libs/gtk+-2.2 ) ) ) )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
@@ -528,7 +528,7 @@ src_compile() {
# GTK+ is preferred over xlib in 3.4.x (xlib is unmaintained
# right now). Much thanks to <csm@gnu.org> for the heads up.
# Travis Tilley <lv@gentoo.org> (11 Jul 2004)
- if ! use build && use gcj && use gtk2
+ if ! use build && use gcj && use gtk
then
myconf="${myconf} --enable-java-awt=gtk"
fi
diff --git a/sys-devel/gcc/gcc-3.4.1-r1.ebuild b/sys-devel/gcc/gcc-3.4.1-r1.ebuild
index a17d71fcdc75..21740aa00d2b 100644
--- a/sys-devel/gcc/gcc-3.4.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r1.ebuild,v 1.3 2004/07/14 23:28:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r1.ebuild,v 1.4 2004/07/19 22:51:23 lv Exp $
-IUSE="static nls bootstrap build multilib gcj gtk2 f77 objc hardened uclibc n32 n64"
+IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
inherit eutils flag-o-matic libtool gnuconfig
@@ -29,7 +29,7 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
>=sys-devel/gcc-config-1.3.1
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
- !build? ( gcj? ( gtk2? ( >=x11-libs/gtk+-2.2 ) ) )
+ !build? ( gcj? ( gtk? ( >=x11-libs/gtk+-2.2 ) ) )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
@@ -541,7 +541,7 @@ src_compile() {
# GTK+ is preferred over xlib in 3.4.x (xlib is unmaintained
# right now). Much thanks to <csm@gnu.org> for the heads up.
# Travis Tilley <lv@gentoo.org> (11 Jul 2004)
- if ! use build && use gcj && use gtk2
+ if ! use build && use gcj && use gtk
then
myconf="${myconf} --enable-java-awt=gtk"
fi
diff --git a/sys-devel/gcc/gcc-3.4.1.ebuild b/sys-devel/gcc/gcc-3.4.1.ebuild
index 60c7d52bbb02..8e026a592125 100644
--- a/sys-devel/gcc/gcc-3.4.1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.8 2004/07/14 23:28:59 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1.ebuild,v 1.9 2004/07/19 22:51:23 lv Exp $
-IUSE="static nls bootstrap build multilib gcj gtk2 f77 objc hardened uclibc n32 n64"
+IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
inherit eutils flag-o-matic libtool gnuconfig
@@ -173,7 +173,7 @@ DEPEND="virtual/libc
>=sys-devel/bison-1.875
>=sys-devel/gcc-config-1.3.1
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-baselibs-1.0 ) )
- !build? ( gcj? ( gtk2? ( >=x11-libs/gtk+-2.2 ) ) )
+ !build? ( gcj? ( gtk? ( >=x11-libs/gtk+-2.2 ) ) )
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
@@ -531,7 +531,7 @@ src_compile() {
# GTK+ is preferred over xlib in 3.4.x (xlib is unmaintained
# right now). Much thanks to <csm@gnu.org> for the heads up.
# Travis Tilley <lv@gentoo.org> (11 Jul 2004)
- if ! use build && use gcj && use gtk2
+ if ! use build && use gcj && use gtk
then
myconf="${myconf} --enable-java-awt=gtk"
fi