summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-07-26 23:49:19 +0000
committerTim Harder <radhermit@gentoo.org>2013-07-26 23:49:19 +0000
commitc2fff10aa109953aa515cba1154bb36779dc092f (patch)
tree5300a630d147d79f534f3faca4cbf1828b831b61 /sys-devel
parentMask =sys-devel/bison-3* for testing. (diff)
downloadgentoo-2-c2fff10aa109953aa515cba1154bb36779dc092f.tar.gz
gentoo-2-c2fff10aa109953aa515cba1154bb36779dc092f.tar.bz2
gentoo-2-c2fff10aa109953aa515cba1154bb36779dc092f.zip
Version bump.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-3.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 61e841b4547f..206901569ccb 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.124 2013/04/17 04:23:11 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.125 2013/07/26 23:49:19 radhermit Exp $
+
+*bison-3.0 (26 Jul 2013)
+
+ 26 Jul 2013; Tim Harder <radhermit@gentoo.org> +bison-3.0.ebuild:
+ Version bump.
*bison-2.7.1 (17 Apr 2013)
diff --git a/sys-devel/bison/bison-3.0.ebuild b/sys-devel/bison/bison-3.0.ebuild
new file mode 100644
index 000000000000..4cd9fa52ebfb
--- /dev/null
+++ b/sys-devel/bison/bison-3.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-3.0.ebuild,v 1.1 2013/07/26 23:49:19 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog-2012 NEWS README THANKS TODO ) # ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED}"/usr/share/${PN}/README "${ED}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}