summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-21 23:15:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-21 23:15:58 +0000
commitbe7c13ac8c84d99106744f1db1e7eb4c7c30c64d (patch)
treeccf4d3cdd1e05186f66e57bfffb4fda96422fb73 /sys-devel
parentClean up ebuild and fix install permissions #24178. (diff)
downloadgentoo-2-be7c13ac8c84d99106744f1db1e7eb4c7c30c64d.tar.gz
gentoo-2-be7c13ac8c84d99106744f1db1e7eb4c7c30c64d.tar.bz2
gentoo-2-be7c13ac8c84d99106744f1db1e7eb4c7c30c64d.zip
Version bump to fix #106780.
(Portage version: 2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/ )
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/makepp/ChangeLog10
-rw-r--r--sys-devel/makepp/files/digest-makepp-1.40.1a1
-rw-r--r--sys-devel/makepp/files/makepp-1.40.1a-install.patch12
-rw-r--r--sys-devel/makepp/makepp-1.40.1a.ebuild42
4 files changed, 63 insertions, 2 deletions
diff --git a/sys-devel/makepp/ChangeLog b/sys-devel/makepp/ChangeLog
index 30434ff5b4c3..5d2447ff05ba 100644
--- a/sys-devel/makepp/ChangeLog
+++ b/sys-devel/makepp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/makepp
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/ChangeLog,v 1.4 2005/01/03 00:08:29 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/ChangeLog,v 1.5 2005/09/21 23:15:58 vapier Exp $
+
+*makepp-1.40.1a (21 Sep 2005)
+
+ 21 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/makepp-1.40.1a-install.patch, +makepp-1.40.1a.ebuild:
+ Version bump to fix #106780.
03 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/sys-devel/makepp/files/digest-makepp-1.40.1a b/sys-devel/makepp/files/digest-makepp-1.40.1a
new file mode 100644
index 000000000000..b3d3f337a355
--- /dev/null
+++ b/sys-devel/makepp/files/digest-makepp-1.40.1a
@@ -0,0 +1 @@
+MD5 0b4d1f205d33b1e6f0ddbcaf554acf91 makepp-1.40.1a.tar.gz 278170
diff --git a/sys-devel/makepp/files/makepp-1.40.1a-install.patch b/sys-devel/makepp/files/makepp-1.40.1a-install.patch
new file mode 100644
index 000000000000..b1ee013add3e
--- /dev/null
+++ b/sys-devel/makepp/files/makepp-1.40.1a-install.patch
@@ -0,0 +1,12 @@
+--- makepp-1.40/config.pl
++++ makepp-1.40/config.pl
+@@ -34,7 +34,7 @@
+ cd makepp-$(VERSION) && make test # Make sure it all runs.
+ rm -rf makepp-$(VERSION)
+
+-install: all
+- $(PERL) install.pl $(BINDIR) $(DATADIR) $(MANDIR) $(HTMLDIR) $(FINDBIN)
++install:
++ $(PERL) install.pl $(DESTDIR)$(BINDIR) $(DESTDIR)$(DATADIR) $(DESTDIR)$(MANDIR) $(DESTDIR)$(HTMLDIR) $(DESTDIR)$(FINDBIN)
+
+ .PHONY: all distribution install test
diff --git a/sys-devel/makepp/makepp-1.40.1a.ebuild b/sys-devel/makepp/makepp-1.40.1a.ebuild
new file mode 100644
index 000000000000..7662a9e2e4a3
--- /dev/null
+++ b/sys-devel/makepp/makepp-1.40.1a.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/makepp-1.40.1a.ebuild,v 1.1 2005/09/21 23:15:58 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.0"
+
+S=${WORKDIR}/${P%.*}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-install.patch
+ # remove ones which cause sandbox violations
+ rm makepp_tests/wildcard_repositories.test
+}
+
+src_compile() {
+ # not an autoconf configure script
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/makepp \
+ || die "configure failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ChangeLog README
+}