summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-11 23:40:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-11 23:40:39 +0000
commitb9b1943b83f502eb2e03dc3d4328bf41472d4518 (patch)
treed329767a38c17c949df180941c5a9e35775f596c /sys-devel
parentInitial ebuild. www-apps/rt dependency (diff)
downloadgentoo-2-b9b1943b83f502eb2e03dc3d4328bf41472d4518.tar.gz
gentoo-2-b9b1943b83f502eb2e03dc3d4328bf41472d4518.tar.bz2
gentoo-2-b9b1943b83f502eb2e03dc3d4328bf41472d4518.zip
Clean up ebuild. License does NOT restrict redistribution, so lets make life easier again. Put all docs in the correct place, instead of under /usr/lib/openmp/*.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/omni/ChangeLog11
-rw-r--r--sys-devel/omni/Manifest3
-rw-r--r--sys-devel/omni/files/digest-omni-1.6-r11
-rw-r--r--sys-devel/omni/omni-1.6-r1.ebuild55
4 files changed, 67 insertions, 3 deletions
diff --git a/sys-devel/omni/ChangeLog b/sys-devel/omni/ChangeLog
index 362f15e25afb..4463970615af 100644
--- a/sys-devel/omni/ChangeLog
+++ b/sys-devel/omni/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/omni
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/ChangeLog,v 1.6 2004/06/24 22:48:38 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/ChangeLog,v 1.7 2005/08/11 23:40:39 robbat2 Exp $
+
+*omni-1.6-r1 (11 Aug 2005)
+
+ 11 Aug 2005; Robin H. Johnson <robbat2@gentoo.org> +omni-1.6-r1.ebuild:
+ Clean up ebuild. License does NOT restrict redistribution, so lets make life
+ easier again. Put all docs in the correct place, instead of under
+ /usr/lib/openmp/*.
23 Jun 2004; Aron Griffis <agriffis@gentoo.org> omni-1.4a.ebuild,
omni-1.6.ebuild:
diff --git a/sys-devel/omni/Manifest b/sys-devel/omni/Manifest
index 033b64bb60fa..bc3757a2a165 100644
--- a/sys-devel/omni/Manifest
+++ b/sys-devel/omni/Manifest
@@ -1,6 +1,7 @@
-MD5 2a5d00ec84d9c780586a678e2e642e45 omni-1.6.ebuild 1630
+MD5 53ecc11479261b5c60f22b663c75e3b2 omni-1.6-r1.ebuild 1435
MD5 ae6755654aafa0a4cb54b4c992a20393 omni-1.4a.ebuild 1630
MD5 6aec73cd889c63b6e34c7807d198e994 ChangeLog 835
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-omni-1.4a 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-omni-1.6 0
+MD5 67279cfb76640bbd8fe4b39013138f55 files/digest-omni-1.6-r1 61
diff --git a/sys-devel/omni/files/digest-omni-1.6-r1 b/sys-devel/omni/files/digest-omni-1.6-r1
new file mode 100644
index 000000000000..0e7b0474a7bc
--- /dev/null
+++ b/sys-devel/omni/files/digest-omni-1.6-r1
@@ -0,0 +1 @@
+MD5 343b3d149ef4da71336199b577cdf862 Omni-1.6.tar.gz 1181195
diff --git a/sys-devel/omni/omni-1.6-r1.ebuild b/sys-devel/omni/omni-1.6-r1.ebuild
new file mode 100644
index 000000000000..13f972d42f2b
--- /dev/null
+++ b/sys-devel/omni/omni-1.6-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/omni-1.6-r1.ebuild,v 1.1 2005/08/11 23:40:39 robbat2 Exp $
+
+IUSE="java doc"
+
+MY_PN="Omni"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="The Omni OpenMP Compiler"
+HOMEPAGE="http://phase.hpcc.jp/Omni/home.html"
+SLOT="0"
+LICENSE="Omni"
+KEYWORDS="~x86"
+
+#RESTRICT="fetch"
+# Read the license more carefully! It does permit redistribution.
+
+DEPEND="java? ( virtual/jdk
+ app-arch/zip )
+ sys-apps/sed"
+
+RDEPEND="java? ( virtual/jdk )"
+SRC_URI="http://www.hpcc.jp/${MY_PN}/ftp/${MY_PN}/${MY_P}.tar.gz"
+
+src_compile() {
+ local myconf=""
+
+ # There is no configure script for the doc
+ if ! use doc ; then
+ dosed s/doc// Makefile.in
+ fi
+
+ use java && myconf="${myconf} --with-jvm=yes"
+ use java || myconf="${myconf} --with-jvm=no"
+
+ use doc && myconf="${myconf} --enable-installSample"
+
+ # scoredoc is just about the placement of the doc
+ econf ${myconf} --enable-gcc --disable-scoreDoc \
+ --with-thread=pthread || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # Put the doc in the right place
+ dodir /usr/share/doc/
+ [ -d ${D}usr/lib/openmp/doc ] && mv ${D}usr/lib/openmp/doc ${D}usr/share/doc/${PF}
+ [ -d ${D}usr/lib/openmp/examples ] && mv ${D}usr/lib/openmp/examples ${D}usr/share/doc/${PF}
+
+ dodoc README COPYRIGHT LICENSE
+}