summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-25 08:41:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-25 08:41:18 +0000
commitb86913a41f5800a77f130c2bf27bbdc7e0feebae (patch)
tree6126576c27d9e82657529efb012aaca8f11be457 /sys-devel
parentdont document flags which shouldnt show up in IUSE (diff)
downloadgentoo-2-b86913a41f5800a77f130c2bf27bbdc7e0feebae.tar.gz
gentoo-2-b86913a41f5800a77f130c2bf27bbdc7e0feebae.tar.bz2
gentoo-2-b86913a41f5800a77f130c2bf27bbdc7e0feebae.zip
Fix bracket quoting in the sanity check and make sure LD_LIBRARY_PATH doesnt clobber wrapped libtool files.
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog9
-rw-r--r--sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch6
-rw-r--r--sys-devel/libtool/files/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch20
-rw-r--r--sys-devel/libtool/libtool-1.5.20.ebuild8
4 files changed, 36 insertions, 7 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 6fc0769c4745..d92e9cb6af31 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/libtool
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.84 2005/09/10 13:43:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.85 2005/09/25 08:41:18 vapier Exp $
+
+ 25 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ files/1.5.10/libtool-1.5.10-version-checking.patch,
+ +files/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch,
+ libtool-1.5.20.ebuild:
+ Fix bracket quoting in the sanity check and make sure LD_LIBRARY_PATH doesnt
+ clobber wrapped libtool files.
10 Sep 2005; Martin Schlemmer <azarah@gentoo.org>
files/1.5.10/libtool-1.5.10-portage.patch:
diff --git a/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch
index 392d81ceabec..da01e4553830 100644
--- a/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch
+++ b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch
@@ -26,17 +26,17 @@
+if test -z "$ltmain"; then
+ AC_MSG_RESULT(no)
+ echo
-+ echo "*** [Gentoo] sanity check failed! ***"
++ echo "*** @<:@Gentoo@:>@ sanity check failed! ***"
+ echo "*** \$ltmain is not defined, please check the patch for consistency! ***"
+ echo
+ exit 1
+fi
+gentoo_lt_version="@_LT_VERSION@"
-+gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
++gentoo_ltmain_version=`grep '^@<:@@<:@:space:@:>@@:>@*VERSION=' $ltmain | sed -e 's|^@<:@@<:@:space:@:>@@:>@*VERSION=||'`
+if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
+ AC_MSG_RESULT(no)
+ echo
-+ echo "*** [Gentoo] sanity check failed! ***"
++ echo "*** @<:@Gentoo@:>@ sanity check failed! ***"
+ echo "*** libtool.m4 and ltmain.sh have a version mismatch! ***"
+ echo "*** (libtool.m4 = $gentoo_lt_version, ltmain.sh = $gentoo_ltmain_version) ***"
+ echo
diff --git a/sys-devel/libtool/files/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch b/sys-devel/libtool/files/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch
new file mode 100644
index 000000000000..f0bdad87ce3c
--- /dev/null
+++ b/sys-devel/libtool/files/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch
@@ -0,0 +1,20 @@
+Fix build time issues with tools who like to export LD_LIBRARY_PATH
+to retarded values.
+
+http://bugs.gentoo.org/99593
+http://lists.gnu.org/archive/html/libtool/2005-09/msg00053.html
+
+--- monkey/ltmain.in
++++ butt/ltmain.in
+@@ -5085,6 +5085,11 @@
+ $echo >> $output "\
+ if test \"\$libtool_execute_magic\" != \"$magic\"; then
+ # Run the actual program with our arguments.
++
++ # Make sure env LD_LIBRARY_PATH does not mess us up
++ if test -n \"\${LD_LIBRARY_PATH+set}\"; then
++ export LD_LIBRARY_PATH=\$progdir:\$LD_LIBRARY_PATH
++ fi
+ "
+ case $host in
+ # Backslashes separate directories on plain windows
diff --git a/sys-devel/libtool/libtool-1.5.20.ebuild b/sys-devel/libtool/libtool-1.5.20.ebuild
index dc8bb39b2b26..19b21efac81a 100644
--- a/sys-devel/libtool/libtool-1.5.20.ebuild
+++ b/sys-devel/libtool/libtool-1.5.20.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.20.ebuild,v 1.1 2005/09/02 05:06:09 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.20.ebuild,v 1.2 2005/09/25 08:41:18 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
-inherit eutils libtool
+inherit eutils
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -106,6 +106,9 @@ src_unpack() {
# In some cases EGREP is not set by the build system.
epatch "${FILESDIR}"/1.5.14/libtool-1.5.14-egrep.patch
+ # Make sure LD_LIBRARY_PATH doesn't override RUNPATH #99593
+ epatch "${FILESDIR}"/1.5.20/libtool-1.5.20-override-LD_LIBRARY_PATH.patch
+
ebegin "Generating ltmain.sh"
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
eend 0
@@ -125,7 +128,6 @@ src_unpack() {
done
cd "${S}"
- uclibctoolize
epunt_cxx
}