summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-08-23 10:42:09 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-08-23 10:42:09 +0000
commitb7344271932d755bd18c58bf56142f085e50695a (patch)
tree8c18688fef7c3a18aa45280989c1829017726b7e /sys-devel
parentdrop invalid comment, this was with gcc 4.6... (diff)
downloadgentoo-2-b7344271932d755bd18c58bf56142f085e50695a.tar.gz
gentoo-2-b7344271932d755bd18c58bf56142f085e50695a.tar.bz2
gentoo-2-b7344271932d755bd18c58bf56142f085e50695a.zip
Backport patch fixing build issues with recent automake, drop my patch that caused bug #399259 by Vu Tran Kien <vutrankien.vn@gmail.com>
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/icecream/ChangeLog12
-rw-r--r--sys-devel/icecream/files/0.9.7-automake-1.11.2.patch16
-rw-r--r--sys-devel/icecream/files/0.9.7-automake.patch32
-rw-r--r--sys-devel/icecream/icecream-0.9.6-r1.ebuild85
-rw-r--r--sys-devel/icecream/icecream-0.9.7-r1.ebuild (renamed from sys-devel/icecream/icecream-0.9.7.ebuild)4
5 files changed, 44 insertions, 105 deletions
diff --git a/sys-devel/icecream/ChangeLog b/sys-devel/icecream/ChangeLog
index 41f6fd8858eb..eb070e4615a4 100644
--- a/sys-devel/icecream/ChangeLog
+++ b/sys-devel/icecream/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/icecream
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.42 2012/05/24 02:41:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.43 2012/08/23 10:42:09 xarthisius Exp $
+
+*icecream-0.9.7-r1 (23 Aug 2012)
+
+ 23 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/0.9.7-automake.patch, +icecream-0.9.7-r1.ebuild,
+ -files/0.9.7-automake-1.11.2.patch, -icecream-0.9.6-r1.ebuild,
+ -icecream-0.9.7.ebuild:
+ Backport patch fixing build issues with recent automake, drop my patch that
+ caused bug #399259 by Vu Tran Kien <vutrankien.vn@gmail.com>
24 May 2012; Mike Frysinger <vapier@gentoo.org> icecream-0.9.6-r1.ebuild,
icecream-0.9.7.ebuild:
@@ -223,4 +232,3 @@
+files/icecream.nokde.patch, +files/icecream_disable.patch,
+files/icecreamdaemon, +files/icecreamscheduler:
Initial import. The ebuild was contributed by Alexander Holler.
-
diff --git a/sys-devel/icecream/files/0.9.7-automake-1.11.2.patch b/sys-devel/icecream/files/0.9.7-automake-1.11.2.patch
deleted file mode 100644
index 6536f555e7de..000000000000
--- a/sys-devel/icecream/files/0.9.7-automake-1.11.2.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix autoreconf with >=automake-1.11.2
-
-https://bugs.gentoo.org/397715
-
-Patch written by Kacper Kowalik <xarthisius@gentoo.org>
---- client/Makefile.am
-+++ client/Makefile.am
-@@ -1,7 +1,7 @@
- INCLUDES = -I$(srcdir)/../services
-
- bin_PROGRAMS = icecc
--pkglib_SCRIPTS = icecc-create-env
-+pkgdata_SCRIPTS = icecc-create-env
- icecc_SOURCES = main.cpp arg.cpp cpp.cpp local.cpp remote.cpp util.cpp md5.c safeguard.cpp
- icecc_LDADD = ../services/libicecc.la $(LIBRSYNC)
- noinst_HEADERS = client.h md5.h util.h
diff --git a/sys-devel/icecream/files/0.9.7-automake.patch b/sys-devel/icecream/files/0.9.7-automake.patch
new file mode 100644
index 000000000000..6905a2a34158
--- /dev/null
+++ b/sys-devel/icecream/files/0.9.7-automake.patch
@@ -0,0 +1,32 @@
+Backport upstream patch to fix automake-1.12 issues
+
+https://bugs.gentoo.org/show_bug.cgi?id=397715
+https://bugs.gentoo.org/show_bug.cgi?id=399259
+--- client/Makefile.am
++++ client/Makefile.am
+@@ -1,10 +1,11 @@
+ INCLUDES = -I$(srcdir)/../services
+
+ bin_PROGRAMS = icecc
+-pkglib_SCRIPTS = icecc-create-env
++pkglibexec_SCRIPTS = icecc-create-env
+ icecc_SOURCES = main.cpp arg.cpp cpp.cpp local.cpp remote.cpp util.cpp md5.c safeguard.cpp
+ icecc_LDADD = ../services/libicecc.la $(LIBRSYNC)
+ noinst_HEADERS = client.h md5.h util.h
++AM_CPPFLAGS = -DPLIBDIR=\"$(pkglibexecdir)\"
+
+ EXTRA_DIST = icecc-create-env
+
+--- configure.in
++++ configure.in
+@@ -246,10 +246,6 @@
+ KDE_EXPAND_MAKEVAR(mybindir, bindir)
+ AC_DEFINE_UNQUOTED(BINDIR, "$mybindir", [Where to look for icecc])
+
+-myopkglibdir='${libdir}/'"$PACKAGE"
+-KDE_EXPAND_MAKEVAR(mypkglibdir, myopkglibdir)
+-AC_DEFINE_UNQUOTED(PLIBDIR, "$mypkglibdir", [Where to look for icecc-create-env])
+-
+ myorundir='${localstatedir}/run'
+ KDE_EXPAND_MAKEVAR(myrundir, myorundir)
+ AC_DEFINE_UNQUOTED(RUNDIR, "$myrundir", [Where to place pid files])
diff --git a/sys-devel/icecream/icecream-0.9.6-r1.ebuild b/sys-devel/icecream/icecream-0.9.6-r1.ebuild
deleted file mode 100644
index 347c2e35272c..000000000000
--- a/sys-devel/icecream/icecream-0.9.6-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.6-r1.ebuild,v 1.2 2012/05/24 02:41:18 vapier Exp $
-
-EAPI=3
-
-inherit base autotools user
-
-MY_P="icecc-${PV}"
-
-DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="http://old-en.opensuse.org/Icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-symlinks.patch"
- "${FILESDIR}/${PV}-crosscompile.patch"
- "${FILESDIR}/${PN}-conf.d-verbosity.patch"
- "${FILESDIR}/${PN}-gentoo-multilib.patch"
-)
-
-pkg_setup() {
- enewgroup icecream
- enewuser icecream -1 -1 /var/cache/icecream icecream
-}
-
-src_prepare() {
- base_src_prepare
-
- eautoreconf
-}
-
-src_install() {
- base_src_install
-
- dosbin "${FILESDIR}"/icecream-config || die "install failed"
- dosbin "${FILESDIR}"/icecream-create-env || die "install failed"
-
- newconfd suse/sysconfig.icecream icecream || die "install failed"
- doinitd "${FILESDIR}"/icecream || die "install failed"
-
- diropts -m0755
- keepdir /usr/lib/icecc/bin
-}
-
-pkg_postinst() {
- ebegin "Scanning for compiler front-ends..."
- /usr/sbin/icecream-config --install-links
- /usr/sbin/icecream-config --install-links "${CHOST}"
- eend ${?}
-
- elog
- elog "If you have compiled binutils/gcc/glibc with processor-specific flags"
- elog "(as normal using Gentoo), there is a greater chance that your compiler"
- elog "won't work on other machines. The best would be to build gcc, glibc and"
- elog "binutils without those flags and then copy the needed files into your"
- elog "tarball for distribution to other machines. This tarball can be created"
- elog "by running /usr/bin/icecc --build-native, and used by setting"
- elog "ICECC_VERSION in /etc/conf.d/icecream"
- elog ' ICECC_VERSION=<filename_of_archive_containing_your_environment>'
- elog
- elog "To use icecream with portage add the following line to /etc/make.conf"
- elog ' PREROOTPATH=/usr/lib/icecc/bin'
- elog
- elog "To use icecream with normal make use (e.g. in /etc/profile)"
- elog ' PATH=/usr/lib/icecc/bin:$PATH'
- elog
- elog "N.B. To use icecream with ccache, the ccache PATH should come first:"
- elog ' PATH=/usr/lib/ccache/bin:/usr/lib/icecc/bin:$PATH'
- elog
- elog "Don't forget to open the following ports in your firewall(s):"
- elog " TCP/10245 on the daemon computers (required)"
- elog " TCP/8765 for the the scheduler computer (required)"
- elog " TCP/8766 for the telnet interface to the scheduler (optional)"
- elog " UDP/8765 for broadcast to find the scheduler (optional)"
- elog
- elog "Further usage instructions: ${HOMEPAGE}"
-}
diff --git a/sys-devel/icecream/icecream-0.9.7.ebuild b/sys-devel/icecream/icecream-0.9.7-r1.ebuild
index 5dee323f3a48..b2e9aa2e1b34 100644
--- a/sys-devel/icecream/icecream-0.9.7.ebuild
+++ b/sys-devel/icecream/icecream-0.9.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.7.ebuild,v 1.3 2012/05/24 02:41:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.7-r1.ebuild,v 1.1 2012/08/23 10:42:09 xarthisius Exp $
EAPI=4
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}/0.9.6-symlinks.patch"
"${FILESDIR}/0.9.6-crosscompile.patch"
- "${FILESDIR}/0.9.7-automake-1.11.2.patch"
+ "${FILESDIR}/${PV}-automake.patch"
"${FILESDIR}/${PN}-conf.d-verbosity.patch"
"${FILESDIR}/${PN}-gentoo-multilib.patch"
)