summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-23 17:49:58 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-23 17:49:58 +0000
commitae19acb2dccce7135cd7815bb8ac0a05129240c6 (patch)
tree917c5b870aa957534517c7b84d8ee8d2512f496d /sys-devel
parentfix configure breaking (diff)
downloadgentoo-2-ae19acb2dccce7135cd7815bb8ac0a05129240c6.tar.gz
gentoo-2-ae19acb2dccce7135cd7815bb8ac0a05129240c6.tar.bz2
gentoo-2-ae19acb2dccce7135cd7815bb8ac0a05129240c6.zip
change to use get_number_of_jobs, else there is a possible 1 out of 6 chance for failing to build
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/3.2.1/gcc-3.2.1-bug-url.patch11
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r7.ebuild9
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r8.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.2.1-r1.ebuild8
-rw-r--r--sys-devel/gcc/gcc-3.2.1-r6.ebuild8
-rw-r--r--sys-devel/gcc/gcc-3.2.1.ebuild5
7 files changed, 47 insertions, 10 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index cfa13911ef56..3d51d4ef4213 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.53 2002/12/16 18:38:14 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.54 2002/12/23 17:49:58 azarah Exp $
+
+ 23 Dec 2002; Martin Schlemmer <azarah@gentoo.org> :
+
+ Fix to use get_number_of_jobs to set -j.
16 Dec 2002; Martin Schlemmer <azarah@gentoo.org> gcc-3.2.1*.ebuild :
diff --git a/sys-devel/gcc/files/3.2.1/gcc-3.2.1-bug-url.patch b/sys-devel/gcc/files/3.2.1/gcc-3.2.1-bug-url.patch
new file mode 100644
index 000000000000..a5156d22b59a
--- /dev/null
+++ b/sys-devel/gcc/files/3.2.1/gcc-3.2.1-bug-url.patch
@@ -0,0 +1,11 @@
+--- gcc-3.2.1/gcc/system.h.orig 2002-12-23 12:13:00.000000000 +0200
++++ gcc-3.2.1/gcc/system.h 2002-12-23 12:13:29.000000000 +0200
+@@ -26,7 +26,7 @@
+ /* This is the location of the online document giving information how
+ to report bugs. If you change this string, also check for strings
+ not under control of the preprocessor. */
+-#define GCCBUGURL "<URL:http://bugzilla.redhat.com/bugzilla/>"
++#define GCCBUGURL "<URL:http://bugs.gentoo.org/>"
+
+ /* We must include stdarg.h/varargs.h before stdio.h. */
+ #ifdef ANSI_PROTOTYPES
diff --git a/sys-devel/gcc/gcc-2.95.3-r7.ebuild b/sys-devel/gcc/gcc-2.95.3-r7.ebuild
index 64ba779f452b..d6e3b20e97d2 100644
--- a/sys-devel/gcc/gcc-2.95.3-r7.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r7.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r7.ebuild,v 1.16 2002/12/16 18:12:40 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r7.ebuild,v 1.17 2002/12/23 17:49:58 azarah Exp $
IUSE="nls static build"
+inherit eutils
+
TV="4.0"
SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/${P}/${P}.tar.gz"
# ftp://ftp.gnu.org/pub/gnu/texinfo/texinfo-${TV}.tar.gz
@@ -53,7 +55,7 @@ src_unpack() {
#
# Azarah - 30 Jun 2002
#
- patch -l -p1 < ${FILESDIR}/${P}-new-atexit.diff || die
+ epatch ${FILESDIR}/${P}-new-atexit.diff
# Now we integrate texinfo-${TV} into gcc. It comes with texinfo-3.12.
# cd ${S}
@@ -98,6 +100,9 @@ src_compile() {
--with-local-prefix=${LOC}/local \
${myconf} || die
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
if [ -z "`use static`" ]
then
emake bootstrap-lean || die
diff --git a/sys-devel/gcc/gcc-2.95.3-r8.ebuild b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
index 2dac7696b271..594fff6cdff2 100644
--- a/sys-devel/gcc/gcc-2.95.3-r8.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.9 2002/12/16 18:38:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r8.ebuild,v 1.10 2002/12/23 17:49:58 azarah Exp $
IUSE="static nls bootstrap java build"
-inherit flag-o-matic gcc
+inherit eutils flag-o-matic gcc
# Compile problems with these (bug #6641 among others)...
filter-flags "-fno-exceptions -fomit-frame-pointer"
@@ -113,8 +113,7 @@ src_unpack() {
#
# Azarah - 30 Jun 2002
#
- einfo "Applying new-atexit patch..."
- patch -l -p1 < ${FILESDIR}/${P}-new-atexit.diff > /dev/null || die
+ epatch ${FILESDIR}/${P}-new-atexit.diff
# Currently if any path is changed via the configure script, it breaks
# installing into ${D}. We should not patch it in src_install() with
@@ -184,6 +183,9 @@ src_compile() {
${myconf} || die
touch ${S}/gcc/c-gperf.h
+
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
einfo "Building GCC..."
if [ -z "`use static`" ]
diff --git a/sys-devel/gcc/gcc-3.2.1-r1.ebuild b/sys-devel/gcc/gcc-3.2.1-r1.ebuild
index 62c015f1d41d..52e5de99d7ba 100644
--- a/sys-devel/gcc/gcc-3.2.1-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r1.ebuild,v 1.3 2002/12/16 18:38:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r1.ebuild,v 1.4 2002/12/23 17:49:58 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -137,6 +137,9 @@ src_unpack() {
then
epatch ${WORKDIR}/patch
fi
+
+ # Fix bug URL
+ epatch ${FILESDIR}/${PV}/${P}-bug-url.patch
# Patches from Redhat ...
epatch ${FILESDIR}/${PV}/gcc32-ada-make.patch
@@ -247,6 +250,9 @@ src_compile() {
then
find ${S} -name '*.[17]' -exec touch {} \; || :
fi
+
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
if [ -z "`use static`" ]
then
diff --git a/sys-devel/gcc/gcc-3.2.1-r6.ebuild b/sys-devel/gcc/gcc-3.2.1-r6.ebuild
index 7617ffe302b0..330476029b75 100644
--- a/sys-devel/gcc/gcc-3.2.1-r6.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r6.ebuild,v 1.3 2002/12/16 18:38:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1-r6.ebuild,v 1.4 2002/12/23 17:49:58 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -148,6 +148,9 @@ src_unpack() {
epatch ${WORKDIR}/patch
fi
+ # Fix bug URL
+ epatch ${FILESDIR}/${PV}/${P}-bug-url.patch
+
# Patches from Redhat ...
epatch ${FILESDIR}/${PV}/gcc32-ada-make.patch
epatch ${FILESDIR}/${PV}/gcc32-shared-pthread.patch
@@ -263,6 +266,9 @@ src_compile() {
find ${S} -name '*.[17]' -exec touch {} \; || :
fi
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
einfo "Building GCC..."
if [ -z "`use static`" ]
then
diff --git a/sys-devel/gcc/gcc-3.2.1.ebuild b/sys-devel/gcc/gcc-3.2.1.ebuild
index bc30e0d1e384..717a73f298c4 100644
--- a/sys-devel/gcc/gcc-3.2.1.ebuild
+++ b/sys-devel/gcc/gcc-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1.ebuild,v 1.11 2002/12/16 18:38:19 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.1.ebuild,v 1.12 2002/12/23 17:49:58 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -198,6 +198,9 @@ src_compile() {
touch ${S}/gcc/c-gperf.h
+ # Setup -j in MAKEOPTS
+ get_number_of_jobs
+
if [ -z "`use static`" ]
then
# Fix for our libtool-portage.patch