summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-07-28 02:53:04 +0000
committerMike Frysinger <vapier@gentoo.org>2015-07-28 02:53:04 +0000
commita9dfc4b53033a429446c6b40504a5d1aeb2112eb (patch)
tree9e142bd45dee58ae0db1c1070a0e93bc2ab606e3 /sys-devel
parentStabilize for all. (diff)
downloadgentoo-2-a9dfc4b53033a429446c6b40504a5d1aeb2112eb.tar.gz
gentoo-2-a9dfc4b53033a429446c6b40504a5d1aeb2112eb.tar.bz2
gentoo-2-a9dfc4b53033a429446c6b40504a5d1aeb2112eb.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gnuconfig/ChangeLog9
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch10
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20150727.ebuild66
-rw-r--r--sys-devel/gnuconfig/gnuconfig-99999999.ebuild6
4 files changed, 82 insertions, 9 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index 316da0a9f04d..e5d6d0ace7f4 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.88 2015/07/28 02:52:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.89 2015/07/28 02:53:04 vapier Exp $
+
+*gnuconfig-20150727 (28 Jul 2015)
+
+ 28 Jul 2015; Mike Frysinger <vapier@gentoo.org> +gnuconfig-20150727.ebuild,
+ files/99999999/0002-Add-x32-support-to-config.guess.patch,
+ gnuconfig-99999999.ebuild:
+ Version bump.
27 Jul 2015; Mike Frysinger <vapier@gentoo.org> gnuconfig-20150308.ebuild:
Stabilize for all.
diff --git a/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch b/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch
index 733acf3f946b..2c69f57878eb 100644
--- a/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch
+++ b/sys-devel/gnuconfig/files/99999999/0002-Add-x32-support-to-config.guess.patch
@@ -1,4 +1,4 @@
-From 7d2e4a41de6d7c231bb10dba6940533c756f3c89 Mon Sep 17 00:00:00 2001
+From 8474d78c459f4ec8f8930094faeaacb2b77bf68f Mon Sep 17 00:00:00 2001
From: "H.J. Lu" <hongjiu.lu@intel.com>
Date: Fri, 20 Dec 2013 14:36:01 -0500
Subject: [PATCH] Add x32 support to config.guess
@@ -16,14 +16,14 @@ URL: http://gcc.gnu.org/ml/gcc-patches/2012-08/msg01083.html
1 file changed, 12 insertions(+), 1 deletion(-)
diff --git a/config.guess b/config.guess
-index f7eb141..8a5d3f4 100755
+index fddac42..17a4f70 100755
--- a/config.guess
+++ b/config.guess
@@ -1038,7 +1038,18 @@ EOF
echo ${UNAME_MACHINE}-dec-linux-${LIBC}
exit ;;
x86_64:Linux:*:*)
-- echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
+- echo ${UNAME_MACHINE}-pc-linux-${LIBC}
+ eval $set_cc_for_build
+ X86_64_ABI=
+ # If there is a compiler, see if it is configured for 32-bit objects.
@@ -35,10 +35,10 @@ index f7eb141..8a5d3f4 100755
+ X86_64_ABI=x32
+ fi
+ fi
-+ echo x86_64-unknown-linux-gnu${X86_64_ABI}
++ echo ${UNAME_MACHINE}-pc-linux-${LIBC}${X86_64_ABI}
exit ;;
xtensa*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
--
-2.3.1
+2.4.4
diff --git a/sys-devel/gnuconfig/gnuconfig-20150727.ebuild b/sys-devel/gnuconfig/gnuconfig-20150727.ebuild
new file mode 100644
index 000000000000..5a1caf4b130d
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20150727.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20150727.ebuild,v 1.1 2015/07/28 02:53:04 vapier Exp $
+
+EAPI="5"
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git
+ http://git.savannah.gnu.org/r/config.git"
+
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} ./* || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-2_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}
diff --git a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
index bfdf91b4da2c..d40cc8c169a2 100644
--- a/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
+++ b/sys-devel/gnuconfig/gnuconfig-99999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-99999999.ebuild,v 1.14 2014/04/15 19:58:08 redlizard Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-99999999.ebuild,v 1.15 2015/07/28 02:53:04 vapier Exp $
-EAPI="2"
+EAPI="5"
inherit eutils
if [[ ${PV} == "99999999" ]] ; then