summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-09 17:42:05 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-09 17:42:05 +0000
commit9e2e98d7f02d75b252f98fb8cd8718c829c88050 (patch)
tree707a8b73b3afa67416794801bd47931a9136772b /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-9e2e98d7f02d75b252f98fb8cd8718c829c88050.tar.gz
gentoo-2-9e2e98d7f02d75b252f98fb8cd8718c829c88050.tar.bz2
gentoo-2-9e2e98d7f02d75b252f98fb8cd8718c829c88050.zip
Version bump #469138 by Antonio Quartulli.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/sparse/ChangeLog11
-rw-r--r--sys-devel/sparse/sparse-0.4.4.ebuild47
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild19
3 files changed, 65 insertions, 12 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index d21be264f92b..e3362a37c6a4 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/sparse
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.53 2012/07/08 17:34:30 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.54 2013/05/09 17:42:05 vapier Exp $
+
+*sparse-0.4.4 (09 May 2013)
+
+ 09 May 2013; Mike Frysinger <vapier@gentoo.org> +sparse-0.4.4.ebuild,
+ sparse-9999.ebuild:
+ Version bump #469138 by Antonio Quartulli.
08 Jul 2012; Raúl Porcel <armin76@gentoo.org> sparse-0.4.3.ebuild:
ia64/s390/sh/sparc stable wrt #418405
@@ -197,4 +203,3 @@
27 Oct 2005; <solar.@gentoo.org> +metadata.xml, +sparse-2005.10.28.ebuild:
- initial commit of sparse. Bug #110656
-
diff --git a/sys-devel/sparse/sparse-0.4.4.ebuild b/sys-devel/sparse/sparse-0.4.4.ebuild
new file mode 100644
index 000000000000..bd86c991ebb9
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.4.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.4.ebuild,v 1.1 2013/05/09 17:42:05 vapier Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git-2
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 4b7d8998496f..5f8232877997 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.11 2012/05/24 02:37:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.12 2013/05/09 17:42:05 vapier Exp $
-EAPI="2"
+EAPI="4"
inherit eutils multilib toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -23,7 +23,7 @@ fi
LICENSE="OSL-1.1"
SLOT="0"
-IUSE="gtk xml"
+IUSE="gtk test xml"
RDEPEND="gtk? ( x11-libs/gtk+:2 )
xml? ( dev-libs/libxml2 )"
@@ -32,15 +32,16 @@ DEPEND="${RDEPEND}
xml? ( virtual/pkgconfig )"
src_prepare() {
+ tc-export AR CC PKG_CONFIG
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
- -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions::}' \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
Makefile || die
- export MAKEOPTS+=" V=1 CC=$(tc-getCC) HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
}
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc FAQ README
+src_compile() {
+ emake $(usex test all all-installable)
}