summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-05 10:26:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-05 10:26:55 +0000
commit996088f7ca2e1c72d198e75cf86fca2617880a4c (patch)
tree564ae3967c8778efea41d49e0f2d1f1ac4bf09aa /sys-devel
parentVersion bump (diff)
downloadgentoo-2-996088f7ca2e1c72d198e75cf86fca2617880a4c.tar.gz
gentoo-2-996088f7ca2e1c72d198e75cf86fca2617880a4c.tar.bz2
gentoo-2-996088f7ca2e1c72d198e75cf86fca2617880a4c.zip
version bump, dont run tests by default, add a src_test, install mk files in /usr/share/mk/P to avoid collisions.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bmake/ChangeLog12
-rw-r--r--sys-devel/bmake/bmake-20080515.ebuild44
-rw-r--r--sys-devel/bmake/files/bmake-20080515-makefile.patch27
-rw-r--r--sys-devel/bmake/files/bmake-tests.patch22
4 files changed, 103 insertions, 2 deletions
diff --git a/sys-devel/bmake/ChangeLog b/sys-devel/bmake/ChangeLog
index 636c5856b991..e94c991de773 100644
--- a/sys-devel/bmake/ChangeLog
+++ b/sys-devel/bmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/bmake
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/ChangeLog,v 1.3 2006/10/23 13:33:40 exg Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/ChangeLog,v 1.4 2008/09/05 10:26:54 aballier Exp $
+
+*bmake-20080515 (05 Sep 2008)
+
+ 05 Sep 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/bmake-20080515-makefile.patch, +files/bmake-tests.patch,
+ +bmake-20080515.ebuild:
+ version bump, dont run tests by default, add a src_test, install mk files
+ in /usr/share/mk/P to avoid collisions.
23 Oct 2006; Emanuele Giaquinta <exg@gentoo.org> bmake-20060728.ebuild:
Add to ~ppc.
diff --git a/sys-devel/bmake/bmake-20080515.ebuild b/sys-devel/bmake/bmake-20080515.ebuild
new file mode 100644
index 000000000000..ece5432aae8d
--- /dev/null
+++ b/sys-devel/bmake/bmake-20080515.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/bmake-20080515.ebuild,v 1.1 2008/09/05 10:26:54 aballier Exp $
+
+inherit eutils
+
+MK_VER=20080716
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${PN}-tests.patch
+}
+
+src_compile() {
+ econf --with-mksrc=../mk --with-default-sys-path=/usr/share/mk/${PN} || die "Configure failed"
+ emake -f makefile.boot bootstrap || die "Compile failed"
+}
+
+src_test() {
+ # $A set by portage confuses the tests...
+ env -u A emake -f makefile.boot check || die "Tests failed"
+}
+
+src_install() {
+ emake -f makefile.boot -j1 DESTDIR="${D}" install-bin install-man || die "Install failed"
+ FORCE_BSD_MK=1 SYS_MK_DIR=. sh ../mk/install-mk -v -m 644 "${D}"/usr/share/mk/${PN} || die "failed to install mk files"
+}
diff --git a/sys-devel/bmake/files/bmake-20080515-makefile.patch b/sys-devel/bmake/files/bmake-20080515-makefile.patch
new file mode 100644
index 000000000000..19c2ab71e9fc
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-20080515-makefile.patch
@@ -0,0 +1,27 @@
+--- makefile.boot.in.old 2006-10-07 12:49:12.000000000 +0200
++++ makefile.boot.in 2006-10-07 13:42:22.000000000 +0200
+@@ -6,6 +6,7 @@
+ #
+ prefix=@prefix@
+ srcdir=@srcdir@
++mandir=@mandir@
+ VPATH=.:$(srcdir)
+ CC=@CC@
+ INSTALL=$(srcdir)/install-sh
+@@ -48,12 +49,12 @@
+ install: install-bin install-man install-mk
+
+ install-bin:
+- test -d ${prefix}/bin || ${INSTALL} -m 755 -d ${prefix}/bin
+- ${INSTALL} -m 755 bmake ${prefix}/bin
++ test -d ${DESTDIR}${prefix}/bin || ${INSTALL} -m 755 -d ${DESTDIR}${prefix}/bin
++ ${INSTALL} -m 755 ${srcdir}/bmake ${DESTDIR}${prefix}/bin
+
+ install-man:
+- test -d ${prefix}/man/cat1 || ${INSTALL} -m 755 -d ${prefix}/man/cat1
+- ${INSTALL} -m 444 ${srcdir}/bmake.cat1 ${prefix}/man/cat1/bmake.1
++ test -d ${DESTDIR}${mandir}/man1 || ${INSTALL} -m 755 -d ${DESTDIR}${mandir}/man1
++ ${INSTALL} -m 444 ${srcdir}/bmake.cat1 ${DESTDIR}${mandir}/man1/bmake.1
+
+ install-mk:
+ @if test -s ${MKSRC}/install-mk; then \
diff --git a/sys-devel/bmake/files/bmake-tests.patch b/sys-devel/bmake/files/bmake-tests.patch
new file mode 100644
index 000000000000..4c6ffe691da3
--- /dev/null
+++ b/sys-devel/bmake/files/bmake-tests.patch
@@ -0,0 +1,22 @@
+Index: bmake/makefile.boot.in
+===================================================================
+--- bmake.orig/makefile.boot.in
++++ bmake/makefile.boot.in
+@@ -31,13 +31,15 @@ BMAKE_ENV= CC="$(CC)" LIBC= MAKEFLAGS= M
+ bootstrap: bmake.boot .mk.done
+ ${BMAKE_ENV} ./bmake.boot -f Makefile
+ ${BMAKE_ENV} ./bmake.boot -f Makefile bmake.1
+- ${BMAKE_ENV} `pwd`/bmake -f Makefile test
+-
++
+ bmake: bmake.boot
+ @echo you might want to try:
+ @echo ${MAKE} -f makefile.boot bootstrap
+ cp bmake.boot $@
+
++check:
++ ${BMAKE_ENV} `pwd`/bmake -f Makefile test
++
+ bmake.boot: ${OBJ}
+ (cd lst.lib; $(MAKE) -f makefile.boot CC="$(CC)" CFLAGS="-I.. -I../${srcdir} -I${srcdir} ${CFLAGS}" )
+ ${CC} *.o lst.lib/*.o -o $@ @LDFLAGS@ @LIBS@