summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-13 11:46:36 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-13 11:46:36 +0000
commit945d11ffc03b3886fe06cdc88499b4bf68097c04 (patch)
treea9deb303a873ff97d40be9be463fd9c80abd4891 /sys-devel
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-945d11ffc03b3886fe06cdc88499b4bf68097c04.tar.gz
gentoo-2-945d11ffc03b3886fe06cdc88499b4bf68097c04.tar.bz2
gentoo-2-945d11ffc03b3886fe06cdc88499b4bf68097c04.zip
it seems that the new SSP doesnt honor _LIBC_PROVIDES_SSP_, so i"ve included a patch that adds this functionality back in
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/files/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch32
-rw-r--r--sys-devel/gcc/gcc-3.4.0-r2.ebuild4
3 files changed, 40 insertions, 3 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 7a6683aa3664..863b78fb82b7 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.242 2004/05/12 18:14:21 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.243 2004/05/13 11:46:36 lv Exp $
+
+ 13 May 2004; Travis Tilley <lv@gentoo.org>
+ +files/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch, gcc-3.4.0-r2.ebuild:
+ it seems that the new SSP doesnt honor _LIBC_PROVIDES_SSP_, so i've included a
+ patch that adds this functionality back in
*gcc-3.4.0-r2 (12 May 2004)
diff --git a/sys-devel/gcc/files/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch b/sys-devel/gcc/files/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch
new file mode 100644
index 000000000000..0e8cca960112
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch
@@ -0,0 +1,32 @@
+diff -urdN gcc-3.4.0.old/gcc/libgcc-std.ver gcc-3.4.0/gcc/libgcc-std.ver
+--- gcc-3.4.0.old/gcc/libgcc-std.ver 2004-05-13 02:41:39.633595352 -0400
++++ gcc-3.4.0/gcc/libgcc-std.ver 2004-05-13 02:46:04.836278416 -0400
+@@ -175,9 +175,11 @@
+ _Unwind_SjLj_ForcedUnwind
+ _Unwind_SjLj_Resume
+
++%if !defined(_LIBC_PROVIDES_SSP_)
+ # stack smash handler symbols
+ __guard
+ __stack_smash_handler
++%endif
+ }
+
+ %inherit GCC_3.3 GCC_3.0
+diff -urdN gcc-3.4.0.old/gcc/libgcc2.c gcc-3.4.0/gcc/libgcc2.c
+--- gcc-3.4.0.old/gcc/libgcc2.c 2004-05-13 02:41:32.928614664 -0400
++++ gcc-3.4.0/gcc/libgcc2.c 2004-05-13 02:48:49.101306336 -0400
+@@ -1669,6 +1669,7 @@
+
+
+ #ifdef L_stack_smash_handler
++#ifndef _LIBC_PROVIDES_SSP_
+ #include <stdio.h>
+ #include <string.h>
+ #include <fcntl.h>
+@@ -1784,4 +1785,5 @@
+ #endif
+ _exit (127);
+ }
++#endif /* _LIBC_PROVIDES_SSP_ */
+ #endif /* L_stack_smash_handler */
diff --git a/sys-devel/gcc/gcc-3.4.0-r2.ebuild b/sys-devel/gcc/gcc-3.4.0-r2.ebuild
index 74d5f3a6fa75..c5610f590c11 100644
--- a/sys-devel/gcc/gcc-3.4.0-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r2.ebuild,v 1.2 2004/05/13 07:52:25 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0-r2.ebuild,v 1.3 2004/05/13 11:46:36 lv Exp $
IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc"
@@ -301,7 +301,6 @@ src_unpack() {
# known to be broken are going to be compiled.
# Travis Tilley <lv@gentoo.org>
use amd64 && use multilib && die "multilib support will not compile yet with gcc 3.4.0. re-emerge with USE=-multilib"
- die "SSP is screwed up at the moment, gimme a few to fix it"
local release_version="Gentoo Linux ${PVR}"
@@ -398,6 +397,7 @@ src_unpack() {
cp ${WORKDIR}/gcc/protector.c ${WORKDIR}/${P}/gcc/ || die "protector.c not found"
cp ${WORKDIR}/gcc/protector.h ${WORKDIR}/${P}/gcc/ || die "protector.h not found"
cp -R ${WORKDIR}/gcc/testsuite/* ${WORKDIR}/${P}/gcc/testsuite/ || die "testsuite not found"
+ epatch ${FILESDIR}/3.4.0/gcc-3.4.0-move-propolice-into-glibc.patch
#use uclibc && epatch ${FILESDIR}/3.3.3/gcc-3.3.3-uclibc-add-ssp.patch