summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-08 06:46:28 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-08 06:46:28 +0000
commit934fb656ccf16c92f5fe6a1137bf021035c015e5 (patch)
treec08e4552507614ddcf591d02984bc73e1a113fda /sys-devel
parentMarked ppc stable for bug #182397. (diff)
downloadgentoo-2-934fb656ccf16c92f5fe6a1137bf021035c015e5.tar.gz
gentoo-2-934fb656ccf16c92f5fe6a1137bf021035c015e5.tar.bz2
gentoo-2-934fb656ccf16c92f5fe6a1137bf021035c015e5.zip
Fixup misc false test failures related to newer versions of autotools in general.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog11
-rw-r--r--sys-devel/automake/automake-1.4_p6.ebuild11
-rw-r--r--sys-devel/automake/automake-1.5.ebuild9
-rw-r--r--sys-devel/automake/automake-1.6.3.ebuild12
-rw-r--r--sys-devel/automake/automake-1.7.9-r1.ebuild12
-rw-r--r--sys-devel/automake/automake-1.8.5-r3.ebuild10
-rw-r--r--sys-devel/automake/automake-1.9.6-r2.ebuild6
-rw-r--r--sys-devel/automake/files/automake-1.6.3-test-fixes.patch28
-rw-r--r--sys-devel/automake/files/automake-1.7.9-test-fixes.patch46
-rw-r--r--sys-devel/automake/files/automake-1.8.5-test-fixes.patch43
10 files changed, 146 insertions, 42 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 86b81247caba..e238ae50aa41 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.105 2007/09/08 02:22:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.106 2007/09/08 06:46:28 vapier Exp $
+
+ 08 Sep 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/automake-1.6.3-test-fixes.patch,
+ +files/automake-1.7.9-test-fixes.patch,
+ +files/automake-1.8.5-test-fixes.patch, automake-1.4_p6.ebuild,
+ automake-1.5.ebuild, automake-1.6.3.ebuild, automake-1.7.9-r1.ebuild,
+ automake-1.8.5-r3.ebuild, automake-1.9.6-r2.ebuild:
+ Fixup misc false test failures related to newer versions of autotools in
+ general.
08 Sep 2007; Mike Frysinger <vapier@gentoo.org> automake-1.10.ebuild:
Set docdir to the right place #154903 by Chris Mayo.
diff --git a/sys-devel/automake/automake-1.4_p6.ebuild b/sys-devel/automake/automake-1.4_p6.ebuild
index 22828572cb89..73e147f3c3df 100644
--- a/sys-devel/automake/automake-1.4_p6.ebuild
+++ b/sys-devel/automake/automake-1.4_p6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6.ebuild,v 1.23 2006/11/03 18:37:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.4_p6.ebuild,v 1.24 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -38,7 +38,7 @@ src_unpack() {
}
src_install() {
- make install DESTDIR="${D}" \
+ emake install DESTDIR="${D}" \
pkgdatadir=/usr/share/automake-${SLOT} \
m4datadir=/usr/share/aclocal-${SLOT} \
|| die
@@ -54,8 +54,3 @@ src_install() {
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOMAKE_1_4=1' syntax has changed to:"
- einfo " WANT_AUTOMAKE=1.4"
-}
diff --git a/sys-devel/automake/automake-1.5.ebuild b/sys-devel/automake/automake-1.5.ebuild
index 0656e3e07621..f4c497e9e77e 100644
--- a/sys-devel/automake/automake-1.5.ebuild
+++ b/sys-devel/automake/automake-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.28 2007/07/11 20:36:28 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.5.ebuild,v 1.29 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -34,7 +34,7 @@ src_unpack() {
}
src_install() {
- make install DESTDIR="${D}" || die "make install failed"
+ emake install DESTDIR="${D}" || die "make install failed"
local x=
for x in aclocal automake ; do
@@ -51,8 +51,3 @@ src_install() {
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOMAKE_1_5=1' syntax has changed to:"
- einfo " WANT_AUTOMAKE=1.5"
-}
diff --git a/sys-devel/automake/automake-1.6.3.ebuild b/sys-devel/automake/automake-1.6.3.ebuild
index ed4c8c7b3fb4..d7e75653acb9 100644
--- a/sys-devel/automake/automake-1.6.3.ebuild
+++ b/sys-devel/automake/automake-1.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.37 2006/11/03 18:37:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.6.3.ebuild,v 1.38 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -26,11 +26,12 @@ src_unpack() {
-e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed failed"
+ epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
export WANT_AUTOCONF=2.5
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
@@ -43,8 +44,3 @@ src_install() {
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOMAKE_1_6=1' syntax has changed to:"
- einfo " WANT_AUTOMAKE=1.6"
-}
diff --git a/sys-devel/automake/automake-1.7.9-r1.ebuild b/sys-devel/automake/automake-1.7.9-r1.ebuild
index 63afdda28466..34193c4c4a94 100644
--- a/sys-devel/automake/automake-1.7.9-r1.ebuild
+++ b/sys-devel/automake/automake-1.7.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.14 2006/11/03 18:37:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.9-r1.ebuild,v 1.15 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -27,11 +27,12 @@ src_unpack() {
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
automake.texi || die "sed texi failed"
epatch "${FILESDIR}"/${P}-infopage-namechange.patch
+ epatch "${FILESDIR}"/${P}-test-fixes.patch
export WANT_AUTOCONF=2.5
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
@@ -44,8 +45,3 @@ src_install() {
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOMAKE_1_7=1' syntax has changed to:"
- einfo " WANT_AUTOMAKE=1.7"
-}
diff --git a/sys-devel/automake/automake-1.8.5-r3.ebuild b/sys-devel/automake/automake-1.8.5-r3.ebuild
index 780d19f3e1ec..39bb78d23ec8 100644
--- a/sys-devel/automake/automake-1.8.5-r3.ebuild
+++ b/sys-devel/automake/automake-1.8.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.14 2007/07/13 12:46:01 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.8.5-r3.ebuild,v 1.15 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -27,11 +27,12 @@ src_unpack() {
-e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
doc/automake.texi || die "sed failed"
epatch "${FILESDIR}"/${PN}-1.8.2-infopage-namechange.patch
+ epatch "${FILESDIR}"/${P}-test-fixes.patch #159557
export WANT_AUTOCONF=2.5
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
rm -f "${D}"/usr/bin/{aclocal,automake}
dodoc NEWS README THANKS TODO AUTHORS ChangeLog
@@ -44,8 +45,3 @@ src_install() {
dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
done
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOMAKE_1_8=1' syntax has changed to:"
- einfo " WANT_AUTOMAKE=1.8"
-}
diff --git a/sys-devel/automake/automake-1.9.6-r2.ebuild b/sys-devel/automake/automake-1.9.6-r2.ebuild
index 417879d536cb..a4203b998d65 100644
--- a/sys-devel/automake/automake-1.9.6-r2.ebuild
+++ b/sys-devel/automake/automake-1.9.6-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r2.ebuild,v 1.14 2006/11/03 18:37:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r2.ebuild,v 1.15 2007/09/08 06:46:28 vapier Exp $
inherit eutils
@@ -36,7 +36,7 @@ src_unpack() {
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
local x
for x in aclocal automake ; do
diff --git a/sys-devel/automake/files/automake-1.6.3-test-fixes.patch b/sys-devel/automake/files/automake-1.6.3-test-fixes.patch
new file mode 100644
index 000000000000..666517754a96
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.6.3-test-fixes.patch
@@ -0,0 +1,28 @@
+Fix the tests so they don't fail :)
+
+depcomp2: #159557 #181484
+fix false positive when using newer autoconf -- it throws a warning based
+on dataroot which causes a failure when there was none
+
+man2: #159557
+grab update from newer automake
+
+--- automake-1.6.3/tests/depcomp2.test
++++ automake-1.6.3/tests/depcomp2.test
+@@ -17,4 +17,5 @@
+ cat > Makefile.am << 'END'
+ SUBDIRS = subdir
++datarootdir = @datarootdir@
+ END
+
+--- automake-1.6.3/tests/man2.test
++++ automake-1.6.3/tests/man2.test
+@@ -23,7 +23,7 @@
+ $AUTOMAKE
+
+ # Let's play with $DESTDIR too, it shouldn't hurt.
+-./configure --prefix=''
++./configure --prefix='' --mandir=/man
+ DESTDIR="`pwd`/=inst" $MAKE -e SHELL=/bin/sh install
+
+ test -f ./=inst/man/man2/foo.2
diff --git a/sys-devel/automake/files/automake-1.7.9-test-fixes.patch b/sys-devel/automake/files/automake-1.7.9-test-fixes.patch
new file mode 100644
index 000000000000..00854886d66d
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.7.9-test-fixes.patch
@@ -0,0 +1,46 @@
+Fix the tests so they don't fail :)
+
+exdir2 man2 transform: #159557 #162565
+grab updates from newer automake
+
+mkdir-tests.m4:
+when mixing newer gettext with this automake, the tests bomb out
+as AM_PROG_MKDIR_P is not provided properly
+
+--- automake-1.7.9/tests/man2.test
++++ automake-1.7.9/tests/man2.test
+@@ -41,7 +41,7 @@
+ $AUTOMAKE
+
+ # Let's play with $DESTDIR too, it shouldn't hurt.
+-./configure --prefix=''
++./configure --prefix='' --mandir=/man
+ DESTDIR="`pwd`/_inst" $MAKE -e install
+
+ test -f ./_inst/man/man2/foo.2
+--- automake-1.7.9/tests/transform.test
++++ automake-1.7.9/tests/transform.test
+@@ -56,7 +56,7 @@
+ $AUTOCONF
+ $AUTOMAKE
+
+-./configure --program-prefix=gnu- --prefix `pwd`/inst
++./configure --program-prefix=gnu- --prefix `pwd`/inst --mandir `pwd`/inst/man
+ $MAKE
+ $MAKE test-install
+ $MAKE uninstall
+--- automake-1.7.9/tests/exdir2.test
++++ automake-1.7.9/tests/exdir2.test
+@@ -23,7 +23,7 @@
+ . ./defs || exit 1
+
+ cat > Makefile.am << 'EOF'
+-html_DATA = zot.html
++quuz_DATA = zot.html
+ pkgdata_DATA = qbert
+ EOF
+
+--- automake-1.7.9/m4/mkdir-tests.m4
++++ automake-1.7.9/m4/mkdir-tests.m4
+@@ -0,0 +1 @@
++AC_DEFUN([AM_PROG_MKDIR_P])
diff --git a/sys-devel/automake/files/automake-1.8.5-test-fixes.patch b/sys-devel/automake/files/automake-1.8.5-test-fixes.patch
new file mode 100644
index 000000000000..43290d1e0d4b
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.8.5-test-fixes.patch
@@ -0,0 +1,43 @@
+Fix the tests so they don't fail :)
+
+exdir2 man2 transform: #159557 #162565
+grab updates from newer automake
+
+--- automake-1.8.5/tests/man2.test
++++ automake-1.8.5/tests/man2.test
+@@ -41,7 +41,7 @@
+ $AUTOMAKE
+
+ # Let's play with $DESTDIR too, it shouldn't hurt.
+-./configure --prefix=''
++./configure --prefix='' --mandir=/man
+ DESTDIR="`pwd`/_inst" $MAKE -e install
+
+ test -f ./_inst/man/man2/foo.2
+--- automake-1.8.5/tests/transform.test
++++ automake-1.8.5/tests/transform.test
+@@ -56,7 +56,7 @@
+ $AUTOCONF
+ $AUTOMAKE
+
+-./configure --program-prefix=gnu- --prefix `pwd`/inst
++./configure --program-prefix=gnu- --prefix `pwd`/inst --mandir `pwd`/inst/man
+ $MAKE
+ $MAKE test-install
+ $MAKE uninstall
+--- automake-1.8.5/tests/exdir2.test
++++ automake-1.8.5/tests/exdir2.test
+@@ -25,11 +25,11 @@
+ set -e
+
+ cat > Makefile.am << 'EOF'
+-html_DATA = zot.html
++quuz_DATA = zot.html
+ pkgdata_DATA = qbert
+ EOF
+
+ $ACLOCAL
+ AUTOMAKE_fails
+ grep 'pkgdatadir' stderr && exit 1
+-grep 'Makefile.am:1:.*htmldir.*undefined' stderr
++grep 'Makefile.am:1:.*quuzdir.*undefined' stderr