summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-13 05:02:33 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-13 05:02:33 +0000
commit8c8a89d7779f3e9fefe97c6e6ddcfa80fbdd3cac (patch)
tree9b38397d34c3a0de95fcaba9328a593a16e00d09 /sys-devel
parentAdd missing Manifest entry for haskell-updater-1.2.0.5-ghc-7.5.patch. (diff)
downloadgentoo-2-8c8a89d7779f3e9fefe97c6e6ddcfa80fbdd3cac.tar.gz
gentoo-2-8c8a89d7779f3e9fefe97c6e6ddcfa80fbdd3cac.tar.bz2
gentoo-2-8c8a89d7779f3e9fefe97c6e6ddcfa80fbdd3cac.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/patch-2.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 5f2ee1c3c411..3283dd947738 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/patch
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.55 2012/04/26 13:35:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.56 2012/09/13 05:02:33 vapier Exp $
+
+*patch-2.7 (13 Sep 2012)
+
+ 13 Sep 2012; Mike Frysinger <vapier@gentoo.org> +patch-2.7.ebuild:
+ Version bump.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> patch-2.6.1.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-devel/patch/patch-2.7.ebuild b/sys-devel/patch/patch-2.7.ebuild
new file mode 100644
index 000000000000..5691a35ae1da
--- /dev/null
+++ b/sys-devel/patch/patch-2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.7.ebuild,v 1.1 2012/09/13 05:02:33 vapier Exp $
+
+inherit flag-o-matic unpacker
+
+DESCRIPTION="Utility to apply diffs to files"
+HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
+SRC_URI="mirror://gnu/patch/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="static test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( sys-apps/ed )"
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf=""
+ [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}