summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-07 19:04:52 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-07 19:04:52 +0000
commit8bc1f8060f0c0d08bd09c6c7a5bfbd16c52f736e (patch)
treeb9cc3f501456bcb4ac25681593465be35701a182 /sys-devel
parentFix for bug #132467 (diff)
downloadgentoo-2-8bc1f8060f0c0d08bd09c6c7a5bfbd16c52f736e.tar.gz
gentoo-2-8bc1f8060f0c0d08bd09c6c7a5bfbd16c52f736e.tar.bz2
gentoo-2-8bc1f8060f0c0d08bd09c6c7a5bfbd16c52f736e.zip
Weekly bump of the 4.2 snapshot
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200605063
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060506.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 99e4c7cff7b8..2d758c562448 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.532 2006/04/29 21:49:35 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.533 2006/05/07 19:04:52 halcy0n Exp $
+
+*gcc-4.2.0_alpha20060506 (07 May 2006)
+
+ 07 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ -gcc-4.2.0_alpha20060429.ebuild, +gcc-4.2.0_alpha20060506.ebuild:
+ Weekly bump of the 4.2 snapshot
*gcc-4.2.0_alpha20060429 (29 Apr 2006)
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060506 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060506
new file mode 100644
index 000000000000..4d47b389737a
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060506
@@ -0,0 +1,3 @@
+MD5 d2c69a69eada979d071298cd17c5fa1b gcc-4.2-20060506.tar.bz2 39028502
+RMD160 6e8e1750904679141b9eeffddd5ad1a90d21af84 gcc-4.2-20060506.tar.bz2 39028502
+SHA256 04c709a6433618fc633cd0935ea3c5e01c4ce632a67e742088f808d29576b0f0 gcc-4.2-20060506.tar.bz2 39028502
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060506.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060506.ebuild
new file mode 100644
index 000000000000..4bf3da8f6b08
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060506.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060506.ebuild,v 1.1 2006/05/07 19:04:52 halcy0n Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-* ~x86 ~amd64"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ dev-libs/gmp
+ dev-libs/mpfr
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? (
+ hppa? ( >=sys-libs/glibc-2.3.4 ) !hppa? ( >=sys-libs/glibc-2.3.6 )
+ )"
+fi
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+ x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}