summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-11-21 17:52:48 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-11-21 17:52:48 +0000
commit8987bda98d13d25042893be79d25af264b7d8652 (patch)
tree7a63d9dc78389dc8b90170878c3e0f10e0cb9cb7 /sys-devel
parentNew distcc-config (and bump to 2.11.2 to force users to get the new config) f... (diff)
downloadgentoo-2-8987bda98d13d25042893be79d25af264b7d8652.tar.gz
gentoo-2-8987bda98d13d25042893be79d25af264b7d8652.tar.bz2
gentoo-2-8987bda98d13d25042893be79d25af264b7d8652.zip
New distcc-config (and bump to 2.11.2 to force users to get the new config) from bug 27432; fixes comment 18
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog8
-rw-r--r--sys-devel/distcc/Manifest6
-rw-r--r--sys-devel/distcc/distcc-2.11.2-r1.ebuild126
-rw-r--r--sys-devel/distcc/files/2.11.1p/distcc-config2
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.11.2-r11
5 files changed, 138 insertions, 5 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index c3f0adb11e37..3d5af542434f 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.83 2003/11/04 03:31:22 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.84 2003/11/21 17:52:44 lisa Exp $
+
+*distcc-2.11.2-r1 (21 Nov 2003)
+
+ 21 Nov 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.11.2-r1.ebuild,
+ files/2.11.1p/distcc-config:
+ New distcc-config from bug 27432; fixes comment 18
03 Nov 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.11.1.ebuild:
Bump to arch on mips for 2.11.1
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index bc42a7fa2dd3..fbdc407f8293 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,5 +1,5 @@
-MD5 222fa358a2cc717d0976005380802487 ChangeLog 14694
-MD5 ba434fcebbfbd2db6cdbd7527edd2080 distcc-2.11.2-r1.ebuild 4052
+MD5 378661e1e8b4b2d84165a8a2f64a84e8 ChangeLog 14882
+MD5 16bbbf9b6b111668ff00046829e6b917 distcc-2.11.2-r1.ebuild 4051
MD5 a1b583a4f17172ee9b85bfaecb7dee21 distcc-2.11.1.ebuild 3927
MD5 6d0efb7bb3a7e30546d91844510da07d distcc-2.5-r1.ebuild 3215
MD5 50800c649c3587e5f0dfef810410abb6 distcc-2.8-r2.ebuild 3365
@@ -20,7 +20,7 @@ MD5 c8ff220b60c105fcede2c72f274995db files/2.11/init 630
MD5 272d85cd71c7dd7eaf3772f895371a41 files/2.11/distcc-config 7560
MD5 66c4af6f8dd87d270e5da50341ca6e14 files/2.11.1p/conf 658
MD5 606dd55609a04a0f21b9875259148332 files/2.11.1p/init 633
-MD5 2854e3e1b1f5dbde737fa518f3f3c28e files/2.11.1p/distcc-config 4687
+MD5 d6231008aeb96f8c680e514d451c6d78 files/2.11.1p/distcc-config 4792
MD5 ee4f0fde9d5e6fe88bf7f513cf12920c files/2.8/001_fix_tempfile.patch.gz 251
MD5 41f782125d594b7249fcd1fc6c306b02 files/2.8/conf 592
MD5 9e01d7b626696716500bbf56c68a5680 files/2.8/distcc-config 7559
diff --git a/sys-devel/distcc/distcc-2.11.2-r1.ebuild b/sys-devel/distcc/distcc-2.11.2-r1.ebuild
new file mode 100644
index 000000000000..353a62f16dfc
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.11.2-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.11.2-r1.ebuild,v 1.1 2003/11/21 17:52:44 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11.1p"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gnome gtk selinux"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version is using a new distcc-config. If you encounter problems with it"
+ ewarn "Please report errors to bug 27432 on the bugs.gentoo.org site"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 10
+}
diff --git a/sys-devel/distcc/files/2.11.1p/distcc-config b/sys-devel/distcc/files/2.11.1p/distcc-config
index a2df2f9e4bf5..950e6ec6dddc 100644
--- a/sys-devel/distcc/files/2.11.1p/distcc-config
+++ b/sys-devel/distcc/files/2.11.1p/distcc-config
@@ -1,7 +1,7 @@
#!/usr/bin/env python
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/distcc-config,v 1.1 2003/10/18 20:18:15 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/distcc-config,v 1.2 2003/11/21 17:52:44 lisa Exp $
import os, re, signal, sys, commands, pwd
from string import rstrip
diff --git a/sys-devel/distcc/files/digest-distcc-2.11.2-r1 b/sys-devel/distcc/files/digest-distcc-2.11.2-r1
new file mode 100644
index 000000000000..d210bdc6c35d
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.11.2-r1
@@ -0,0 +1 @@
+MD5 034bc9c36bd5c3d9c26241600510927b distcc-2.11.2.tar.bz2 253066