summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-02-05 02:52:07 +0000
committerAron Griffis <agriffis@gentoo.org>2004-02-05 02:52:07 +0000
commit836a770707f70b23016744ab22c4bf41cf3be404 (patch)
treea3610c5a77cde3746eee58279b7f55cc1e31e580 /sys-devel
parenthello ~amd64 (diff)
downloadgentoo-2-836a770707f70b23016744ab22c4bf41cf3be404.tar.gz
gentoo-2-836a770707f70b23016744ab22c4bf41cf3be404.tar.bz2
gentoo-2-836a770707f70b23016744ab22c4bf41cf3be404.zip
Fix bug 29017 by replacing -march=k6 and -march=k6-2 with -march=i586. Fix bug
39842 by restricting optimization on amd64 to -O0. Mark stable on x86. Remove icc cruft (leftover from 2002) and remove IUSE=build since it isn't true.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/ChangeLog8
-rw-r--r--sys-devel/bison/bison-1.875.ebuild46
2 files changed, 31 insertions, 23 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 6e213ed5f88f..f4b066a841d1 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/bison
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.23 2004/02/01 10:54:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.24 2004/02/05 02:52:07 agriffis Exp $
+
+ 04 Feb 2004; Aron Griffis <agriffis@gentoo.org> bison-1.875.ebuild:
+ Fix bug 29017 by replacing -march=k6 and -march=k6-2 with -march=i586. Fix bug
+ 39842 by restricting optimization on amd64 to -O0. Mark stable on x86.
+ Remove icc cruft (leftover from 2002) and remove IUSE="build" since it isn't
+ true.
01 Feb 2004; Joshua Kinard <kumba@gentoo.org> bison-1.34-r1.ebuild,
bison-1.35.ebuild, bison-1.75.ebuild, bison-1.875.ebuild:
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index 37bd8bc6fe19..fe07262f04f4 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,51 +1,53 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.9 2004/02/01 10:54:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.10 2004/02/05 02:52:07 agriffis Exp $
-IUSE="nls static build" # icc"
+inherit gcc
+
+IUSE="nls static"
S="${WORKDIR}/${P}"
DESCRIPTION="A yacc-compatible parser generator"
SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
-
LICENSE="GPL-2"
SLOT="0"
-# do not compile xfree
-KEYWORDS="amd64 ~x86 ~ppc ~sparc alpha mips hppa ~arm ia64 ppc64"
+KEYWORDS="amd64 x86 ~ppc ~sparc alpha mips hppa ~arm ia64 ppc64"
DEPEND="sys-devel/m4
nls? ( sys-devel/gettext )"
-# icc? ( dev-lang/icc )"
-
src_unpack() {
- unpack ${A}
-
- cd ${S}
+ unpack ${A} && cd ${S} || die
epatch ${FILESDIR}/${PN}-1.32-extfix.patch
epatch ${FILESDIR}/${PN}-1.875-gccerror.patch
}
src_compile() {
+ # Bug 39842 says that bison segfaults when built on amd64 with
+ # optimizations. This will probably be fixed in a future gcc
+ # version, but for the moment just disable optimizations for that
+ # arch (04 Feb 2004 agriffis)
+ [[ $ARCH == amd64 ]] && append-flags -O0
+
+ # Bug 29017 says that bison has compile-time issues with
+ # -march=k6 and -march=k6-2 prior to 3.4CVS. Use -march=i586
+ # instead (04 Feb 2004 agriffis)
+ if [[ $(gcc-major-version) == 3 && $(gcc-minor-version) < 4 ]]; then
+ CFLAGS=${CFLAGS//-march=k6-2/-march=i586}
+ CFLAGS=${CFLAGS//-march=k6/-march=i586}
+ fi
- local myconf=
-
- use nls || myconf="--disable-nls"
-# use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
-
- econf ${myconf} || die
+ econf $(use_enable nls) || die
- if [ -z "`use static`" ]
- then
- emake || die
- else
+ if use static; then
emake LDFLAGS="-static" || die
+ else
+ emake || die
fi
}
src_install() {
-
make DESTDIR=${D} \
datadir=/usr/share \
mandir=/usr/share/man \
@@ -53,7 +55,7 @@ src_install() {
install || die
# This one is installed by dev-util/yacc
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison
+ mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
# We do not need this.
rm -f ${D}/usr/lib/liby.a