summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-11 16:59:15 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-11 16:59:15 +0000
commit827f5b89f4d6ea7c08cbed5eb95e4a979c4e9485 (patch)
treebfa8fb94037a1acccdc18ab63a5c5a42eb1c05b8 /sys-devel
parentMark stable for all. (diff)
downloadgentoo-2-827f5b89f4d6ea7c08cbed5eb95e4a979c4e9485.tar.gz
gentoo-2-827f5b89f4d6ea7c08cbed5eb95e4a979c4e9485.tar.bz2
gentoo-2-827f5b89f4d6ea7c08cbed5eb95e4a979c4e9485.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gnuconfig/ChangeLog9
-rw-r--r--sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch18
-rw-r--r--sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch18
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20130111.ebuild62
4 files changed, 88 insertions, 19 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index b1ac9af57731..6ecbe7ebd196 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.68 2013/01/11 16:58:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.69 2013/01/11 16:59:14 vapier Exp $
+
+*gnuconfig-20130111 (11 Jan 2013)
+
+ 11 Jan 2013; Mike Frysinger <vapier@gentoo.org> +gnuconfig-20130111.ebuild,
+ files/99999999/0001-add-uClibc-guess-support.patch,
+ files/99999999/0002-add-ps2-targets-to-config.sub.patch:
+ Version bump.
11 Jan 2013; Mike Frysinger <vapier@gentoo.org> gnuconfig-20121010.ebuild:
Mark stable for all.
diff --git a/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
index 619ab0461138..5d8b5730b30a 100644
--- a/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
+++ b/sys-devel/gnuconfig/files/99999999/0001-add-uClibc-guess-support.patch
@@ -1,17 +1,17 @@
-From 2be577b2bbffeccec254d146f78e8a915c8bb989 Mon Sep 17 00:00:00 2001
+From 42ac774a89dd11d5056b806845abb95508469173 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 9 Oct 2008 15:51:09 -0400
Subject: [PATCH 1/2] add uClibc guess support
---
- config.guess | 99 +++++++++++++++++++++++++++++++++------------------------
- 1 files changed, 57 insertions(+), 42 deletions(-)
+ config.guess | 99 ++++++++++++++++++++++++++++++++++--------------------------
+ 1 file changed, 57 insertions(+), 42 deletions(-)
diff --git a/config.guess b/config.guess
-index d622a44..a3b0d66 100755
+index 0aee604..8905e54 100755
--- a/config.guess
+++ b/config.guess
-@@ -138,6 +138,29 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
+@@ -136,6 +136,29 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` || UNAME_RELEASE=unknown
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
@@ -41,7 +41,7 @@ index d622a44..a3b0d66 100755
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
-@@ -852,21 +875,21 @@ EOF
+@@ -857,21 +880,21 @@ EOF
exit ;;
*:GNU:*:*)
# the GNU system
@@ -67,7 +67,7 @@ index d622a44..a3b0d66 100755
exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
-@@ -879,59 +902,51 @@ EOF
+@@ -884,59 +907,51 @@ EOF
EV68*) UNAME_MACHINE=alphaev68 ;;
esac
objdump --private-headers /bin/sh | grep -q ld.so.1
@@ -141,7 +141,7 @@ index d622a44..a3b0d66 100755
exit ;;
mips:Linux:*:* | mips64:Linux:*:*)
eval $set_cc_for_build
-@@ -950,54 +965,54 @@ EOF
+@@ -955,54 +970,54 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep '^CPU'`
@@ -213,5 +213,5 @@ index d622a44..a3b0d66 100755
i*86:DYNIX/ptx:4*:*)
# ptx 4.0 does uname -s correctly, with DYNIX/ptx in there.
--
-1.7.8.4
+1.8.0.2
diff --git a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
index 6de5412ecee1..5e2da82ac70b 100644
--- a/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
+++ b/sys-devel/gnuconfig/files/99999999/0002-add-ps2-targets-to-config.sub.patch
@@ -1,18 +1,18 @@
-From e7e57625c8b118ef851c9f46cbd3ff8d30d1b1fe Mon Sep 17 00:00:00 2001
+From 498d79139147953da13db30afc594ede214543d9 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Thu, 9 Oct 2008 15:51:35 -0400
Subject: [PATCH 2/2] add ps2 targets to config.sub
---
- config.sub | 22 ++++++++++++++++++++--
- 1 files changed, 20 insertions(+), 2 deletions(-)
+ config.sub | 22 ++++++++++++++++++++--
+ 1 file changed, 20 insertions(+), 2 deletions(-)
diff --git a/config.sub b/config.sub
-index c894da4..42adc67 100755
+index 707e9e2..de08881 100755
--- a/config.sub
+++ b/config.sub
-@@ -257,7 +257,7 @@ case $basic_machine in
- | be32 | be64 \
+@@ -262,7 +262,7 @@ case $basic_machine in
+ | be32 | be64 \
| bfin \
| c4x | clipper \
- | d10v | d30v | dlx | dsp16xx \
@@ -20,7 +20,7 @@ index c894da4..42adc67 100755
| epiphany \
| fido | fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
-@@ -800,6 +800,24 @@ case $basic_machine in
+@@ -812,6 +812,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
@@ -45,7 +45,7 @@ index c894da4..42adc67 100755
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
-@@ -1358,7 +1376,7 @@ case $os in
+@@ -1374,7 +1392,7 @@ case $os in
| -uxpv* | -beos* | -mpeix* | -udk* \
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
@@ -55,5 +55,5 @@ index c894da4..42adc67 100755
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
--
-1.7.8.4
+1.8.0.2
diff --git a/sys-devel/gnuconfig/gnuconfig-20130111.ebuild b/sys-devel/gnuconfig/gnuconfig-20130111.ebuild
new file mode 100644
index 000000000000..746db536e219
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20130111.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20130111.ebuild,v 1.1 2013/01/11 16:59:14 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git
+ http://git.savannah.gnu.org/r/config.git"
+
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-2_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}