summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-16 15:21:59 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-16 15:21:59 +0000
commit7c0b2088b22c4a10ccb15c1b5d05140b3d9ba9d5 (patch)
tree09cdef4934e96e8ababaf89901cc1c77720d44a5 /sys-devel
parentStabilize for all. (diff)
downloadgentoo-2-7c0b2088b22c4a10ccb15c1b5d05140b3d9ba9d5.tar.gz
gentoo-2-7c0b2088b22c4a10ccb15c1b5d05140b3d9ba9d5.tar.bz2
gentoo-2-7c0b2088b22c4a10ccb15c1b5d05140b3d9ba9d5.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gnuconfig/ChangeLog7
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20130516.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index c566e53072cc..fc305e418253 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.72 2013/05/16 15:21:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.73 2013/05/16 15:21:59 vapier Exp $
+
+*gnuconfig-20130516 (16 May 2013)
+
+ 16 May 2013; Mike Frysinger <vapier@gentoo.org> +gnuconfig-20130516.ebuild:
+ Version bump.
16 May 2013; Mike Frysinger <vapier@gentoo.org> gnuconfig-20130111.ebuild:
Stabilize for all.
diff --git a/sys-devel/gnuconfig/gnuconfig-20130516.ebuild b/sys-devel/gnuconfig/gnuconfig-20130516.ebuild
new file mode 100644
index 000000000000..e164f798611f
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20130516.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20130516.ebuild,v 1.1 2013/05/16 15:21:59 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git
+ http://git.savannah.gnu.org/r/config.git"
+
+ inherit git-2
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(gawk '{ gsub(/-/, "", $1); print $1; exit }' ChangeLog)
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-2_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}