summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-17 23:48:23 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-17 23:48:23 +0000
commit7b53d5268a86c5e1206d7222558d92a4dd1d297b (patch)
treee13e50a2129ca3745a5cd34f776b9a1a2721cd86 /sys-devel
parentupdated digest (diff)
downloadgentoo-2-7b53d5268a86c5e1206d7222558d92a4dd1d297b.tar.gz
gentoo-2-7b53d5268a86c5e1206d7222558d92a4dd1d297b.tar.bz2
gentoo-2-7b53d5268a86c5e1206d7222558d92a4dd1d297b.zip
update distcc ebuild again, getting bugs 15048 and 15769 fully closed
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog8
-rw-r--r--sys-devel/distcc/distcc-1.1-r10.ebuild79
-rw-r--r--sys-devel/distcc/files/digest-distcc-1.1-r101
-rw-r--r--sys-devel/distcc/files/distccd.433
4 files changed, 120 insertions, 1 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 089425dac255..5515fac541db 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,12 +1,18 @@
# ChangeLog for sys-devel/distcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.21 2003/02/17 20:37:06 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.22 2003/02/17 23:48:23 zwelch Exp $
+
+*distcc-1.1-r10 (17 Feb 2003)
+
+ 17 Feb 2003; Zach Welch <zwelch@gentoo.org> :
+ Add /var/run/distccd for pid and distcc user... (bugs 15048 and 15769)
*distcc-1.1-r9 (17 Feb 2003)
17 Feb 2003; Zach Welch <zwelch@gentoo.org> :
Fix location of pid file... (bug 15769)
Fix einfo Portage version reference
+ (THIS VERSION IS BROKEN - ztw)
*distcc-1.1-r8 (10 Feb 2003)
diff --git a/sys-devel/distcc/distcc-1.1-r10.ebuild b/sys-devel/distcc/distcc-1.1-r10.ebuild
new file mode 100644
index 000000000000..b5a3bfc2c268
--- /dev/null
+++ b/sys-devel/distcc/distcc-1.1-r10.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-1.1-r10.ebuild,v 1.1 2003/02/17 23:48:23 zwelch Exp $
+
+inherit eutils
+
+IUSE=""
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ dev-libs/popt"
+
+src_unpack() {
+ unpack distcc-${PV}.tar.bz2
+ cp -a distcc-${PV} distcc-${PV}.orig
+ epatch "${FILESDIR}/wrapper-${PV}.patch"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ cd "${D}/usr/share/info" && rm -f distcc.info.gz
+
+ docinto "../${PN}"
+ dodoc "${S}/survey.txt"
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/distccd.4" distccd
+
+ # Search the PATH now that gcc doesn't live in /usr/bin
+ # ztw - this needs to be moved into an installed script so
+ # users/portage can re-run it after installing new compilers
+ einfo "Scanning for compiler front-ends"
+ dodir /usr/lib/distcc/bin
+ diropts -m0755 -o distcc -g daemon
+ touch ${D}/usr/lib/distcc/bin/.keep
+ for a in gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++; do
+ if [ -n "$(type -p ${a})" ]; then
+ dosym /usr/bin/distcc /usr/lib/distcc/bin/${a}
+ fi
+ done
+
+ dodir /var/run/distccd
+ diropts -m0755 -o distcc -g daemon
+ touch ${D}/var/run/distccd/.keep
+}
+
+pkg_preinst() {
+ local USERFIX
+ # update or create, depending on whether user already exists
+ einfo "Updating or creating distcc user..."
+ id distcc 2> /dev/null && USERFIX=usermod || USERFIX=useradd
+ ${USERFIX} -g daemon -s /bin/false -d /dev/null -c "distccd" distcc || \
+ die "Failed to \`${USERFIX} distcc\` user"
+}
+
+pkg_postinst() {
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the distcc dir AFTER ccache."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf (and define"
+ einfo "DISTCC_HOSTS as well). Do NOT set CC=distcc or similar."
+ einfo "See http://cvs.gentoo.org/~zwelch/distcc.html for details."
+}
+
diff --git a/sys-devel/distcc/files/digest-distcc-1.1-r10 b/sys-devel/distcc/files/digest-distcc-1.1-r10
new file mode 100644
index 000000000000..cbdb7de8f495
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-1.1-r10
@@ -0,0 +1 @@
+MD5 ad2a433dbe4361baffa8dc5f24ba2be7 distcc-1.1.tar.bz2 207370
diff --git a/sys-devel/distcc/files/distccd.4 b/sys-devel/distcc/files/distccd.4
new file mode 100644
index 000000000000..438cff847133
--- /dev/null
+++ b/sys-devel/distcc/files/distccd.4
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+
+DISTCCD_EXEC=/usr/bin/distccd
+DISTCCD_PIDFILE=/var/run/distccd/distccd.pid
+
+depend() {
+ need net
+}
+
+start() {
+ rm -rf ${DISTCCD_PIDFILE}
+ ebegin "Starting distccd"
+ PATH="$(gcc-config --get-bin-path):${PATH}" \
+ /sbin/start-stop-daemon --start --quiet \
+ --startas ${DISTCCD_EXEC} \
+ -c distcc --pidfile ${DISTCCD_PIDFILE} \
+ -- --pid-file ${DISTCCD_PIDFILE}
+ eend $? "Failed to Start distccd"
+}
+
+stop() {
+ ebegin "Stopping distccd"
+ start-stop-daemon --stop --quiet --pidfile ${DISTCC_PIDFILE}
+ rm -rf ${DISTCC_PIDFILE}
+ eend $? "Failed to Stop distccd"
+}
+
+restart() {
+ ebegin "Restarting distccd"
+ svc_stop
+ svc_start
+ eend $? "Failed to Restart distccd"
+}