summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-06-06 01:48:46 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-06-06 01:48:46 +0000
commit7a3a5d978b7f29e3605eb46df107dfb21fcf0c23 (patch)
treec74d1960a0ff6d406a827a1d78a47638b2405ae2 /sys-devel
parentRemoved gcc-config from DEPEND as it's not neccessary. (diff)
downloadgentoo-2-7a3a5d978b7f29e3605eb46df107dfb21fcf0c23.tar.gz
gentoo-2-7a3a5d978b7f29e3605eb46df107dfb21fcf0c23.tar.bz2
gentoo-2-7a3a5d978b7f29e3605eb46df107dfb21fcf0c23.zip
Updating gcc-config-2* ebuild to rc1, so users don't need to download a different tarball than for eselect-compiler when it gets unmasked. There is actually no change in the wrapper other than the version number.
(Portage version: 2.1_rc4-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog10
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc13
-rw-r--r--sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild28
3 files changed, 40 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 1ca397e0b44d..dd52bbc56f9b 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.127 2006/04/25 00:20:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.128 2006/06/06 01:48:46 eradicator Exp $
+
+*gcc-config-2.0.0_rc1 (06 Jun 2006)
+
+ 06 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ -gcc-config-2.0.0_beta2.ebuild, +gcc-config-2.0.0_rc1.ebuild:
+ Updating gcc-config-2* ebuild to rc1, so users don't need to download a
+ different tarball than for eselect-compiler when it gets unmasked. There is
+ actually no change in the wrapper other than the version number.
*gcc-config-1.3.13-r2 (25 Apr 2006)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1 b/sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1
new file mode 100644
index 000000000000..e5670a7296b1
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-2.0.0_rc1
@@ -0,0 +1,3 @@
+MD5 b67d2f339f159da455d19c49e4868d9c compiler-config-2.0.0_rc1.tar.gz 117180
+RMD160 dbcd8120139c75f40ae2405746ab2a5f26e810b4 compiler-config-2.0.0_rc1.tar.gz 117180
+SHA256 a911a7b0a1184c576500df8530e77823f976dce387001c581ba89ac8edfe30c2 compiler-config-2.0.0_rc1.tar.gz 117180
diff --git a/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild b/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..ac84918ef209
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-2.0.0_rc1.ebuild,v 1.1 2006/06/06 01:48:46 eradicator Exp $
+
+DESCRIPTION="Utility to configure the active toolchain compiler"
+HOMEPAGE="http://www.gentoo.org/"
+
+MY_PN="compiler-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI=" http://dev.gentoo.org/~eradicator/toolchain/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-compiler-${PV}"
+
+src_compile() {
+ # Just need to make gcc-config from gcc-config.in
+ econf
+}
+
+src_install() {
+ dobin src/profile-manager/gcc-config
+}