summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-28 00:19:36 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-28 00:19:36 +0000
commit7a2c0b50c803c9a16cbbc3721b78171e242ba44e (patch)
tree473199434de450195da4b28972d94f3066896423 /sys-devel
parentRevbump to fix undefined symbol error at runtime when built with --as-needed ... (diff)
downloadgentoo-2-7a2c0b50c803c9a16cbbc3721b78171e242ba44e.tar.gz
gentoo-2-7a2c0b50c803c9a16cbbc3721b78171e242ba44e.tar.bz2
gentoo-2-7a2c0b50c803c9a16cbbc3721b78171e242ba44e.zip
Update to EAPI=4 and version bump.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-20120227.ebuild35
-rw-r--r--sys-devel/crossdev/crossdev-99999999.ebuild10
3 files changed, 47 insertions, 6 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 1f1cbd9dfd97..e08abcda2ac9 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.89 2012/02/14 20:28:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.90 2012/02/28 00:19:36 vapier Exp $
+
+*crossdev-20120227 (28 Feb 2012)
+
+ 28 Feb 2012; Mike Frysinger <vapier@gentoo.org> +crossdev-20120227.ebuild,
+ crossdev-99999999.ebuild:
+ Update to EAPI=4 and version bump.
*crossdev-20120214 (14 Feb 2012)
diff --git a/sys-devel/crossdev/crossdev-20120227.ebuild b/sys-devel/crossdev/crossdev-20120227.ebuild
new file mode 100644
index 000000000000..5e848536f3b1
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20120227.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20120227.ebuild,v 1.1 2012/02/28 00:19:36 vapier Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}
diff --git a/sys-devel/crossdev/crossdev-99999999.ebuild b/sys-devel/crossdev/crossdev-99999999.ebuild
index 373cdcb035b0..ebdff8052a69 100644
--- a/sys-devel/crossdev/crossdev-99999999.ebuild
+++ b/sys-devel/crossdev/crossdev-99999999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.5 2011/07/14 04:13:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-99999999.ebuild,v 1.6 2012/02/28 00:19:36 vapier Exp $
-EAPI="3"
+EAPI="4"
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
@@ -28,8 +28,8 @@ RDEPEND=">=sys-apps/portage-2.1
DEPEND="app-arch/xz-utils"
src_install() {
- emake install DESTDIR="${D}" || die
+ default
if [[ "${PV}" == "99999999" ]] ; then
- dosed "s:@CDEVPV@:${EGIT_VERSION}:" /usr/bin/crossdev || die
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
fi
}