summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-10 04:51:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-10 04:51:43 +0000
commit6d755dd4161a0434048eead6ac7a37942b00f265 (patch)
tree621a502f4238fcb927112da069b4300cd84e08f7 /sys-devel
parentadded paths for boost to build all targets with icc (diff)
downloadgentoo-2-6d755dd4161a0434048eead6ac7a37942b00f265.tar.gz
gentoo-2-6d755dd4161a0434048eead6ac7a37942b00f265.tar.bz2
gentoo-2-6d755dd4161a0434048eead6ac7a37942b00f265.zip
Add sanity checks for host system and add support for avr (fixes from Scott L Price).
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/crossdev-0.9.1.ebuild (renamed from sys-devel/crossdev/crossdev-0.9-r3.ebuild)2
-rwxr-xr-xsys-devel/crossdev/files/crossdev23
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.1 (renamed from sys-devel/crossdev/files/digest-crossdev-0.9-r3)0
4 files changed, 27 insertions, 7 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 56caace4ed33..9c8384b6ce18 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.10 2005/03/04 18:59:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.11 2005/03/10 04:51:42 vapier Exp $
+
+*crossdev-0.9.1 (09 Mar 2005)
+
+ 09 Mar 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ -crossdev-0.9-r3.ebuild, +crossdev-0.9.1.ebuild:
+ Add sanity checks for host system and add support for avr (fixes from Scott
+ L Price).
*crossdev-0.9-r3 (04 Mar 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9-r3.ebuild b/sys-devel/crossdev/crossdev-0.9.1.ebuild
index c0f8c4416ca4..4518fbb515cd 100644
--- a/sys-devel/crossdev/crossdev-0.9-r3.ebuild
+++ b/sys-devel/crossdev/crossdev-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9-r3.ebuild,v 1.2 2005/03/08 23:39:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.1.ebuild,v 1.1 2005/03/10 04:51:42 vapier Exp $
DESCRIPTION="Gentoo Cross-toolchain generator"
HOMEPAGE="http://www.gentoo.org/"
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 31aac149ab92..c155d94f6e0e 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.7 2005/03/10 04:27:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.8 2005/03/10 04:51:43 vapier Exp $
source /sbin/functions.sh || exit 1
die() {
@@ -53,6 +53,9 @@ parse_target() {
# Let's accept ARCH in both the portage and the standard forms ...
# CTARGET is in the standard form while TARCH is in the portage form
case ${CPRE} in
+
+ #####################
+ ### linux targets ###
alpha*) TARCH=alpha;;
arm*) TARCH=arm;;
hppa*) TARCH=hppa;;
@@ -70,9 +73,19 @@ parse_target() {
sh*) TARCH=sh;;
x86_64*) TARCH=amd64;;
amd64) TARCH=amd64; CPRE="x86_64";;
- *) usage 1;;
+
+ #####################
+ ### other targets ###
+ avr*) TARCH=${HARCH};
+ CPOST=""; STAGE=1; GUSE="-fortran -gtk nocxx -gcj -objc";;
+
+ #######################
+ ### unknown targets ###
+ *) usage 1;;
esac
- CTARGET=${CPRE}-${CPOST}
+
+ CTARGET=${CPRE}
+ [[ -n ${CPOST} ]] && CTARGET=${CTARGET}-${CPOST}
}
hr() {
local c=${COLUMNS:-0}
@@ -96,7 +109,7 @@ UOPTS=
TARCH=
HARCH=$(env -uARCH portageq envvar ARCH)
CTARGET=
-STAGE=3
+STAGE=4
BVER="[latest]" ; BUSE=""
GVER="[latest]" ; GUSE=""
KVER="[latest]" ; KUSE=""
@@ -111,7 +124,7 @@ while [[ $# -gt 0 ]] ; do
--g|--gcc) shift; GVER=$1;;
--k|--kernel) shift; KVER=$1;;
--l|--libc) shift; LVER=$1;;
- -s?|--stage?) STAGE=${1:0-1};;
+ -s?|--stage?) [[ ${STAGE} -eq 4 ]] && STAGE=${1:0-1};;
-a|-b|-p|-v) UOPTS="${UOPTS} $1";;
-h|--help) usage;;
*) eerror "UNKNOWN OPTION: '$1'" ; usage 1;;
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9-r3 b/sys-devel/crossdev/files/digest-crossdev-0.9.1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/crossdev/files/digest-crossdev-0.9-r3
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.1