summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-04-18 00:14:27 +0000
committerZack Welch <zwelch@gentoo.org>2003-04-18 00:14:27 +0000
commit6d71a2266ed19deb33938680cee6d609b7c6e8e9 (patch)
treef1cf841c140ffd67fabdc44aa49058a695a0e1a2 /sys-devel
parentfixed var scrollkeeper with make install (diff)
downloadgentoo-2-6d71a2266ed19deb33938680cee6d609b7c6e8e9.tar.gz
gentoo-2-6d71a2266ed19deb33938680cee6d609b7c6e8e9.tar.bz2
gentoo-2-6d71a2266ed19deb33938680cee6d609b7c6e8e9.zip
fix distcc-config to add DCCC_QUIET
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog5
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/files/1.2.3/distcc-config6
3 files changed, 9 insertions, 6 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 53110dbc8440..2c2feebb4f20 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-devel/distcc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.39 2003/04/17 18:48:27 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.40 2003/04/18 00:14:24 zwelch Exp $
*distcc-2.0.1 (31 Mar 2003)
+ 17 Apr 2003; Zach Welch <zwelch@gentoo.org> files/1.2.3/distcc-config:
+ fix distcc-config to add DCCC_QUIET
+
31 Mar 2003; Zach Welch <zwelch@gentoo.org> distcc-2.0.1.ebuild,
files/1.2.3/distcc-config:
bump version to close bug 18566; masquerade patch now mainlined
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 8bdbdbaed327..8546971fd066 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,4 +1,4 @@
-MD5 cbe186b2ca223d45d68fd34246d89c47 ChangeLog 6307
+MD5 67bc6494ed4261335de705e6e97c4361 ChangeLog 6419
MD5 56a795e9b01a51ee8d06b0025d598666 distcc-0.12.ebuild 755
MD5 8345d0afbdc7ba12864a3dfec341e913 distcc-1.2.ebuild 2672
MD5 674f0be5b4083d6218f5b2af9bd4c9e2 distcc-1.1-r11.ebuild 2562
@@ -27,7 +27,7 @@ MD5 9bad5d7dc8c33d22ff42efcc299f1067 files/digest-distcc-1.2.3-r3 65
MD5 3250d3022ba56c3c5951c023a6263e22 files/digest-distcc-1.1-r11 63
MD5 9a3a39b4f229559e6a855d777c6fe807 files/digest-distcc-2.0.1 65
MD5 6bc82bf32667e5398497b2dae88f1033 files/1.2.3/wrapper.patch 5242
-MD5 5d39125cc20bcfab04ccbf2ce224307a files/1.2.3/distcc-config 6427
+MD5 4269806341d0e1b7beaf92369bff89b9 files/1.2.3/distcc-config 6473
MD5 d4fd07d7d3d3e3952baef8c654d2715f files/1.2.3/info.patch 545
MD5 a103f965186c1fd631caa36e79d65a5e files/1.2.1/wrapper.patch 5242
MD5 d2f03086d9f3b2a2888702f1ca415330 files/1.2.1/distcc-config 3193
diff --git a/sys-devel/distcc/files/1.2.3/distcc-config b/sys-devel/distcc/files/1.2.3/distcc-config
index 8e2a7942651a..1d3f03cc2817 100644
--- a/sys-devel/distcc/files/1.2.3/distcc-config
+++ b/sys-devel/distcc/files/1.2.3/distcc-config
@@ -18,13 +18,13 @@
DCCC_ENV_FILE="${ROOT}etc/env.d/02distcc"
DCCC_OLD_ENV="${ROOT}etc/env.d/04distcc"
-# this should be getopt'd someday
+# this should be getopt'd someday (override with DCCC_QUIET)
DCCC_VERBOSE=1
source /sbin/functions.sh
dccc_echo() {
- [ -n "${DCCC_VERBOSE}" ] && echo "$*"
+ [ -z "${DCCC_QUIET}" -a -n "${DCCC_VERBOSE}" ] && echo "$*"
}
dccc_exit() {
dccc_echo "$*"
@@ -51,7 +51,7 @@ dccc_install_link() {
# note: this `type' doesn't do the right thing if ROOT != /
if [ -n "$(type -p ${1})" ]; then
# first be sure any old link is removed
- DCCC_VERBOSE="" dccc_remove_link "${1}"
+ DCCC_QUIET=1 dccc_remove_link "${1}"
# then create the new link
local t="${ROOT}usr/lib/distcc/bin/${1}"