summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-14 17:53:27 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-14 17:53:27 +0000
commit6a0d013d0de26a6f168839c4584c5811384a8bdd (patch)
treef3dfe60c4d1e0bfcc5f2c32ca7d190f44902fc95 /sys-devel
parent Added -mtune to ALLOWED_FLAGS for mips. (Manifest recommit) (diff)
downloadgentoo-2-6a0d013d0de26a6f168839c4584c5811384a8bdd.tar.gz
gentoo-2-6a0d013d0de26a6f168839c4584c5811384a8bdd.tar.bz2
gentoo-2-6a0d013d0de26a6f168839c4584c5811384a8bdd.zip
fix slot
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.4.2-r1.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-3.4.2-r1.ebuild b/sys-devel/gcc/gcc-3.4.2-r1.ebuild
index 8ba1a850746b..6f4449547790 100644
--- a/sys-devel/gcc/gcc-3.4.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.2-r1.ebuild,v 1.3 2004/09/14 12:50:08 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.2-r1.ebuild,v 1.4 2004/09/14 17:53:27 lv Exp $
IUSE="static nls bootstrap build nomultilib gcj gtk f77 objc hardened uclibc n32 n64"
@@ -59,6 +59,19 @@ ETYPE="gcc-compiler"
HARDENED_GCC_WORKS="x86 sparc amd64"
SPLIT_SPECS="true"
+# Ok, this is a hairy one again, but lets assume that we
+# are not cross compiling, than we want SLOT to only contain
+# $PV, as people upgrading to new gcc layout will not have
+# their old gcc unmerged ...
+# GCC 3.4 introduces a new version of libstdc++
+if [ "${CHOST}" == "${CCHOST}" ]
+then
+ SLOT="${MY_PV}"
+else
+ SLOT="${CCHOST}-${MY_PV}"
+fi
+
+
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
# still having issues with optimizations, or with it not filtering bad