summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-12-11 06:18:21 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-12-11 06:18:21 +0000
commit689fe1a730a775ed387deee33ef4c5c8b4f8817c (patch)
treeb1d377798a5a59a1d6697ec9958a6e0648ddba6a /sys-devel
parentadded ~sparc (bug 348218) (diff)
downloadgentoo-2-689fe1a730a775ed387deee33ef4c5c8b4f8817c.tar.gz
gentoo-2-689fe1a730a775ed387deee33ef4c5c8b4f8817c.tar.bz2
gentoo-2-689fe1a730a775ed387deee33ef4c5c8b4f8817c.zip
Version bump. Adds support for copying over extended attributes such as
file-based capabilities. (Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/prelink/ChangeLog8
-rw-r--r--sys-devel/prelink/prelink-20101123.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/sys-devel/prelink/ChangeLog b/sys-devel/prelink/ChangeLog
index 1d70286be2c0..c747eee86ff4 100644
--- a/sys-devel/prelink/ChangeLog
+++ b/sys-devel/prelink/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/prelink
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/ChangeLog,v 1.78 2010/09/19 09:16:52 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/ChangeLog,v 1.79 2010/12/11 06:18:21 dirtyepic Exp $
+
+*prelink-20101123 (11 Dec 2010)
+
+ 11 Dec 2010; Ryan Hill <dirtyepic@gentoo.org> +prelink-20101123.ebuild:
+ Version bump. Adds support for copying over extended attributes such as
+ file-based capabilities.
19 Sep 2010; Ryan Hill <dirtyepic@gentoo.org>
-files/prelink-20040707-init.patch,
diff --git a/sys-devel/prelink/prelink-20101123.ebuild b/sys-devel/prelink/prelink-20101123.ebuild
new file mode 100644
index 000000000000..2bf0ca1688b0
--- /dev/null
+++ b/sys-devel/prelink/prelink-20101123.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20101123.ebuild,v 1.1 2010/12/11 06:18:21 dirtyepic Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
+HOMEPAGE="http://people.redhat.com/jakub/prelink"
+#SRC_URI="http://people.redhat.com/jakub/prelink/${P}.tar.bz2"
+# if not on http://people.redhat.com/jakub/prelink/, releases can usually be ripped from
+# http://mirrors.kernel.org/fedora/development/source/SRPMS/prelink-<blah>.src.rpm
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -arm ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/elfutils-0.100
+ !dev-libs/libelf
+ >=sys-libs/glibc-2.8"
+RDEPEND="${DEPEND}
+ >=sys-devel/binutils-2.18"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20061201-prelink-conf.patch
+
+ sed -i -e 's:undosyslibs.sh::' testsuite/Makefile.in #254201
+ sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
+
+ # older GCCs don't support this flag
+ # sed it from the Makefile then add it back to CFLAGS so we can use
+ # strip-unsupported-flags
+ sed -i -e 's:-Wno-pointer-sign::' src/Makefile.in #325269
+ append-cflags -Wno-pointer-sign
+ strip-unsupported-flags
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install Failed"
+
+ insinto /etc
+ doins doc/prelink.conf || die
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/prelink.cron prelink
+ newconfd "${FILESDIR}"/prelink.confd prelink
+
+ dodir /var/{lib/misc,log}
+ touch "${D}/var/lib/misc/prelink.full"
+ touch "${D}/var/lib/misc/prelink.quick"
+ touch "${D}/var/lib/misc/prelink.force"
+ touch "${D}/var/log/prelink.log"
+
+ dodoc TODO ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
+ elog "found online at:"
+ elog
+ elog " http://www.gentoo.org/doc/en/prelink-howto.xml"
+ elog
+ elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
+ echo
+ touch "${ROOT}/var/lib/misc/prelink.force"
+}