summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-11-12 19:24:02 +0000
committerFabian Groffen <grobian@gentoo.org>2013-11-12 19:24:02 +0000
commit68467c680ae66b30b79962ccfe41af1bde138c19 (patch)
tree83d933746e6a874b0d007da07f32cd5668d59691 /sys-devel
parentVersion bump, add test dep on dev-python/SaltTesting. (diff)
downloadgentoo-2-68467c680ae66b30b79962ccfe41af1bde138c19.tar.gz
gentoo-2-68467c680ae66b30b79962ccfe41af1bde138c19.tar.bz2
gentoo-2-68467c680ae66b30b79962ccfe41af1bde138c19.zip
Add patch to solve compilation problem on Mavericks
(Portage version: 2.2.7-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-apple/ChangeLog8
-rw-r--r--sys-devel/binutils-apple/binutils-apple-4.3.ebuild5
-rw-r--r--sys-devel/binutils-apple/files/ld64-128.2-stdlib.patch14
3 files changed, 23 insertions, 4 deletions
diff --git a/sys-devel/binutils-apple/ChangeLog b/sys-devel/binutils-apple/ChangeLog
index a82d4aa9bb83..9f30910c63cd 100644
--- a/sys-devel/binutils-apple/ChangeLog
+++ b/sys-devel/binutils-apple/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/binutils-apple
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.34 2012/08/12 18:58:06 grobian Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/ChangeLog,v 1.35 2013/11/12 19:24:02 grobian Exp $
+
+ 12 Nov 2013; Fabian Groffen <grobian@gentoo.org>
+ +files/ld64-128.2-stdlib.patch, binutils-apple-4.3.ebuild:
+ Add patch to solve compilation problem on Mavericks
12 Aug 2012; Fabian Groffen <grobian@gentoo.org> binutils-apple-3.2.ebuild,
binutils-apple-4.3.ebuild:
diff --git a/sys-devel/binutils-apple/binutils-apple-4.3.ebuild b/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
index bed18e0c50c5..0c301320a9bb 100644
--- a/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
+++ b/sys-devel/binutils-apple/binutils-apple-4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.3.ebuild,v 1.3 2012/08/12 18:58:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-apple/binutils-apple-4.3.ebuild,v 1.4 2013/11/12 19:24:02 grobian Exp $
EAPI="3"
@@ -66,6 +66,7 @@ src_prepare() {
cd "${S}"/${LD64}/src
cp "${FILESDIR}"/ld64-128.2-Makefile Makefile
epatch "${FILESDIR}"/ld64-127.2-lto.patch
+ epatch "${FILESDIR}"/ld64-128.2-stdlib.patch
ln -s ../../${CCTOOLS}/include
cp other/prune_trie.h include/mach-o/ || die
diff --git a/sys-devel/binutils-apple/files/ld64-128.2-stdlib.patch b/sys-devel/binutils-apple/files/ld64-128.2-stdlib.patch
new file mode 100644
index 000000000000..8bbcb46cf9c5
--- /dev/null
+++ b/sys-devel/binutils-apple/files/ld64-128.2-stdlib.patch
@@ -0,0 +1,14 @@
+Patch by Linlin Yan <yanlinlin82@gmail.com>
+
+https://bugs.gentoo.org/show_bug.cgi?id=490932
+
+--- ld64-128.2/src/other/rebase.cpp
++++ ld64-128.2/src/other/rebase.cpp
+@@ -29,6 +29,7 @@
+ #include <limits.h>
+ #include <stdarg.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <unistd.h>