summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-28 22:56:42 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-28 22:56:42 +0000
commit5e842a265a60f030db49572bcdc75cbe086b3d7e (patch)
tree910e1efa3cb962c58ca75f29b060a77d6486ad1c /sys-devel
parentStable arm, bug #495624 (diff)
downloadgentoo-2-5e842a265a60f030db49572bcdc75cbe086b3d7e.tar.gz
gentoo-2-5e842a265a60f030db49572bcdc75cbe086b3d7e.tar.bz2
gentoo-2-5e842a265a60f030db49572bcdc75cbe086b3d7e.zip
Fix building R600 target, bug #496308.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-3.3-r2.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index e9275b428de4..3861112e62c5 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.161 2013/12/28 19:13:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.162 2013/12/28 22:56:42 mgorny Exp $
+
+ 28 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-3.3-r2.ebuild:
+ Fix building R600 target, bug #496308.
28 Dec 2013; Michał Górny <mgorny@gentoo.org> llvm-3.3-r2.ebuild:
Fix clang blocker to match 3.3-r100.
diff --git a/sys-devel/llvm/llvm-3.3-r2.ebuild b/sys-devel/llvm/llvm-3.3-r2.ebuild
index 3b2ea5fe4c9a..aef1974f4f7c 100644
--- a/sys-devel/llvm/llvm-3.3-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r2.ebuild,v 1.2 2013/12/28 19:13:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.3-r2.ebuild,v 1.3 2013/12/28 22:56:42 mgorny Exp $
EAPI=5
@@ -206,10 +206,13 @@ multilib_src_configure() {
targets='all'
else
targets='host,cpp'
- use video_cards_radeon && targets+=',r600'
fi
conf_flags+=( --enable-targets=${targets} )
+ if use video_cards_radeon; then
+ conf_flags+=( --enable-experimental-targets=R600 )
+ fi
+
if multilib_build_binaries; then
use gold && conf_flags+=( --with-binutils-include="${EPREFIX}"/usr/include/ )
# extra commas don't hurt
@@ -245,6 +248,10 @@ cmake_configure() {
# but it's fairly easy to steal this from configured autotools
local targets=$(sed -n -e 's/^TARGETS_TO_BUILD=//p' Makefile.config || die)
local libdir=$(get_libdir)
+
+ # cmake doesn't have R600 in 3.3
+ targets=${targets/R600 /}
+
local mycmakeargs=(
-DLLVM_TARGETS_TO_BUILD="${targets// /;}"
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}