summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-04-23 06:32:01 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-04-23 06:32:01 +0000
commit548331a6cadf21287a3524777ce86a45e89d30fb (patch)
treee91773b5d6a86ecc3121b04bc6c2b934b05f7b30 /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-548331a6cadf21287a3524777ce86a45e89d30fb.tar.gz
gentoo-2-548331a6cadf21287a3524777ce86a45e89d30fb.tar.bz2
gentoo-2-548331a6cadf21287a3524777ce86a45e89d30fb.zip
Version bump. Fixes bug #411691 (ICE building stable boost) and bug #454426
(bootstrap fails on alpha). (Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/gcc-4.6.4.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 42ed202d1785..2e81fee133a5 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.945 2013/04/21 02:31:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.946 2013/04/23 06:32:01 dirtyepic Exp $
+
+*gcc-4.6.4 (23 Apr 2013)
+
+ 23 Apr 2013; Ryan Hill <dirtyepic@gentoo.org> +gcc-4.6.4.ebuild:
+ Version bump. Fixes bug #411691 (ICE building stable boost) and bug #454426
+ (bootstrap fails on alpha).
21 Apr 2013; Mike Frysinger <vapier@gentoo.org> gcc-4.4.7.ebuild,
gcc-4.5.4.ebuild, gcc-4.6.3.ebuild, gcc-4.7.2-r1.ebuild, gcc-4.8.0.ebuild:
diff --git a/sys-devel/gcc/gcc-4.6.4.ebuild b/sys-devel/gcc/gcc-4.6.4.ebuild
new file mode 100644
index 000000000000..c1c138bdb662
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.6.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.4.ebuild,v 1.1 2013/04/23 06:32:01 dirtyepic Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.2"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.32
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ ewarn
+ ewarn "LTO support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of LTO will not be fixed."
+ ewarn
+}