summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-10-28 00:25:12 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-10-28 00:25:12 +0000
commit507a7a2c7cb573567d3253df727f54c510f2b23f (patch)
tree2a134044dbcf2c21aac8771eb6367aaab252bccd /sys-devel
parentAdd dsn patch that applies, but needs testing, bug #489242 (diff)
downloadgentoo-2-507a7a2c7cb573567d3253df727f54c510f2b23f.tar.gz
gentoo-2-507a7a2c7cb573567d3253df727f54c510f2b23f.tar.bz2
gentoo-2-507a7a2c7cb573567d3253df727f54c510f2b23f.zip
added ccache support (bug #486402)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-3.3-r100.ebuild16
-rw-r--r--sys-devel/clang/clang-9999-r100.ebuild16
3 files changed, 35 insertions, 3 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index a3a037d230a3..2275989c42c6 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.98 2013/09/05 19:08:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.99 2013/10/28 00:25:12 ottxor Exp $
+
+ 28 Oct 2013; Christoph Junghans <ottxor@gentoo.org> clang-3.3-r100.ebuild,
+ clang-9999-r100.ebuild:
+ added ccache support (bug #486402)
05 Sep 2013; Michał Górny <mgorny@gentoo.org> clang-3.2.ebuild,
clang-3.3.ebuild, clang-9999.ebuild:
diff --git a/sys-devel/clang/clang-3.3-r100.ebuild b/sys-devel/clang/clang-3.3-r100.ebuild
index 2ecb84268f7b..f608c426f749 100644
--- a/sys-devel/clang/clang-3.3-r100.ebuild
+++ b/sys-devel/clang/clang-3.3-r100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.6 2013/08/27 19:28:06 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.3-r100.ebuild,v 1.7 2013/10/28 00:25:12 ottxor Exp $
EAPI=5
@@ -20,3 +20,17 @@ RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analy
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system
# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
diff --git a/sys-devel/clang/clang-9999-r100.ebuild b/sys-devel/clang/clang-9999-r100.ebuild
index 2b4d194dba4f..256d6c69cf4d 100644
--- a/sys-devel/clang/clang-9999-r100.ebuild
+++ b/sys-devel/clang/clang-9999-r100.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.4 2013/08/14 13:03:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999-r100.ebuild,v 1.5 2013/10/28 00:25:12 ottxor Exp $
EAPI=5
@@ -20,3 +20,17 @@ RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analy
# Please keep this package around since it's quite likely that we'll
# return to separate LLVM & clang ebuilds when the cmake build system
# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}