summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-22 12:01:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-22 12:01:53 +0000
commit4b451828c99e2db3c60e0e66685a58842dfd87a2 (patch)
treeb6336b652391c39a8bd731a7c949c38eacdcad7f /sys-devel
parentChange Python USEdep to ssl(+) due to change in dev-python/pypy. Drop old. (diff)
downloadgentoo-2-4b451828c99e2db3c60e0e66685a58842dfd87a2.tar.gz
gentoo-2-4b451828c99e2db3c60e0e66685a58842dfd87a2.tar.bz2
gentoo-2-4b451828c99e2db3c60e0e66685a58842dfd87a2.zip
Add missing llvm-3.3-insecure-rpath.patch.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/files/llvm-3.3-insecure-rpath.patch30
2 files changed, 35 insertions, 1 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 4e384ee76aae..a0bcd1f61184 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.117 2013/07/21 10:02:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.118 2013/07/22 12:01:53 mgorny Exp $
+
+ 22 Jul 2013; Michał Górny <mgorny@gentoo.org>
+ +files/llvm-3.3-insecure-rpath.patch:
+ Add missing llvm-3.3-insecure-rpath.patch.
21 Jul 2013; Michał Górny <mgorny@gentoo.org>
+files/clang-3.1-gentoo-runtime-gcc-detection-v3.patch:
diff --git a/sys-devel/llvm/files/llvm-3.3-insecure-rpath.patch b/sys-devel/llvm/files/llvm-3.3-insecure-rpath.patch
new file mode 100644
index 000000000000..659f23783810
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-3.3-insecure-rpath.patch
@@ -0,0 +1,30 @@
+From d23d21bc76693dd2a43b5d76c68972ac01a055ba Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Sat, 20 Jul 2013 15:56:56 +0200
+Subject: [PATCH] Remove insecure RUNPATHs.
+
+LLVM seems to build fine without them, and they were removed for 3.4
+already.
+---
+ Makefile.rules | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/Makefile.rules b/Makefile.rules
+index db252f7..a29481b 100644
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -639,11 +639,6 @@ ifneq ($(HOST_OS), $(filter $(HOST_OS), Cygwin MingW))
+ ifneq ($(HOST_OS), Darwin)
+ ifdef TOOLNAME
+ LD.Flags += $(RPATH) -Wl,'$(PROJ_libdir)'
+- ifdef EXAMPLE_TOOL
+- LD.Flags += $(RPATH) -Wl,$(ExmplDir) $(DynamicFlag)
+- else
+- LD.Flags += $(RPATH) -Wl,$(ToolDir) $(DynamicFlag)
+- endif
+ endif
+ else
+ ifneq ($(DARWIN_MAJVERS),4)
+--
+1.8.3.2
+