summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-06-04 05:25:51 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-06-04 05:25:51 +0000
commit4952a6630ac39e18e392a6309f2d5fc0ff1c8012 (patch)
treedfc4cc1db887216f226b211c9efe6ccb795f1ad3 /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-4952a6630ac39e18e392a6309f2d5fc0ff1c8012.tar.gz
gentoo-2-4952a6630ac39e18e392a6309f2d5fc0ff1c8012.tar.bz2
gentoo-2-4952a6630ac39e18e392a6309f2d5fc0ff1c8012.zip
Version bump (bug #472116).
Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.8.1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 74f602760153..5ecc5e588767 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.951 2013/05/20 10:56:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.952 2013/06/04 05:25:51 dirtyepic Exp $
+
+*gcc-4.8.1 (04 Jun 2013)
+
+ 04 Jun 2013; Ryan Hill <dirtyepic@gentoo.org> +gcc-4.8.1.ebuild:
+ Version bump (bug #472116).
20 May 2013; Alexis Ballier <aballier@gentoo.org> gcc-4.7.0.ebuild,
gcc-4.7.1.ebuild, gcc-4.7.2-r1.ebuild, gcc-4.7.3.ebuild:
diff --git a/sys-devel/gcc/gcc-4.8.1.ebuild b/sys-devel/gcc/gcc-4.8.1.ebuild
new file mode 100644
index 000000000000..9447cf88f09f
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.1.ebuild,v 1.1 2013/06/04 05:25:51 dirtyepic Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.6"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+"
+
+KEYWORDS=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ if use lto ; then
+ ewarn
+ ewarn "LTO support is still experimental and unstable. Any bug reports"
+ ewarn "about LTO that do not include an upstream patch will be closed as"
+ ewarn "invalid."
+ ewarn
+ fi
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ elog
+ elog "Packages failing to build with GCC 4.8 are tracked at"
+ elog "https://bugs.gentoo.org/461954"
+ elog
+}