summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-05 04:00:19 +0000
committerMike Frysinger <vapier@gentoo.org>2009-04-05 04:00:19 +0000
commit432d3108a172cce40c7e13b765a8ed94a577e170 (patch)
tree128fa924a1119ce3e572782dfe6fea21c028a7f9 /sys-devel
parentVersion bumped. Fixed dependency. (diff)
downloadgentoo-2-432d3108a172cce40c7e13b765a8ed94a577e170.tar.gz
gentoo-2-432d3108a172cce40c7e13b765a8ed94a577e170.tar.bz2
gentoo-2-432d3108a172cce40c7e13b765a8ed94a577e170.zip
Fix from upstream for handling of little endian fortran on SuperH #264303 by Raúl Porcel.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog9
-rw-r--r--sys-devel/autoconf/autoconf-2.63-r1.ebuild45
-rw-r--r--sys-devel/autoconf/files/autoconf-2.63-sh.patch32
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index d41844370840..f270fb5a6531 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.129 2009/04/01 16:35:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.130 2009/04/05 04:00:19 vapier Exp $
+
+*autoconf-2.63-r1 (05 Apr 2009)
+
+ 05 Apr 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/autoconf-2.63-sh.patch, +autoconf-2.63-r1.ebuild:
+ Fix from upstream for handling of little endian fortran on SuperH #264303
+ by Raúl Porcel.
*autoconf-2.63b (01 Apr 2009)
diff --git a/sys-devel/autoconf/autoconf-2.63-r1.ebuild b/sys-devel/autoconf/autoconf-2.63-r1.ebuild
new file mode 100644
index 000000000000..2837d651de7b
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.63-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.63-r1.ebuild,v 1.1 2009/04/05 04:00:19 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-6"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-sh.patch #264303
+}
+
+src_compile() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+ # From configure output:
+ # Parallel builds via `make -jN' do not work.
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}
diff --git a/sys-devel/autoconf/files/autoconf-2.63-sh.patch b/sys-devel/autoconf/files/autoconf-2.63-sh.patch
new file mode 100644
index 000000000000..8008b32b6022
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.63-sh.patch
@@ -0,0 +1,32 @@
+http://bugs.gentoo.org/264303
+http://lists.gnu.org/archive/html/bug-autoconf/2008-10/msg00040.html
+
+From: Chikama Masaki <masaki.chikama@gmail.com>
+Date: Fri, 24 Oct 2008 01:41:06 +0000 (-0600)
+Subject: For gfortran on sh, ignore -little.
+X-Git-Tag: v2.63b~206
+X-Git-Url: http://git.savannah.gnu.org/gitweb/?p=autoconf.git;a=commitdiff_plain;h=3f38aad
+
+For gfortran on sh, ignore -little.
+
+* lib/autoconf/fortran.m4 (_AC_FC_LIBRARY_LDFLAGS): Add -little to
+list of ignored arguments.
+* THANKS: Update.
+
+Signed-off-by: Eric Blake <ebb9@byu.net>
+---
+
+diff --git a/lib/autoconf/fortran.m4 b/lib/autoconf/fortran.m4
+index 20d9e0c..ad0c2ee 100644
+--- a/lib/autoconf/fortran.m4
++++ b/lib/autoconf/fortran.m4
+@@ -686,7 +686,8 @@ while test $[@%:@] != 1; do
+ [_AC_LINKER_OPTION([$ac_arg], ac_cv_[]_AC_LANG_ABBREV[]_libs)])
+ ;;
+ # Ignore these flags.
+- -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
++ -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -little \
++ |-LANG:=* | -LIST:* | -LNO:*)
+ ;;
+ -lkernel32)
+ test x"$CYGWIN" != xyes && ac_cv_[]_AC_LANG_ABBREV[]_libs="$ac_cv_[]_AC_LANG_ABBREV[]_libs $ac_arg"