summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2010-06-21 22:49:21 +0000
committerMagnus Granberg <zorry@gentoo.org>2010-06-21 22:49:21 +0000
commit411430183a2e4a538a99b0c9fa30218919e36db2 (patch)
treece9a37b39fb9b34f23f1661e78fc3d559608351b /sys-devel
parentRemove bogus deps and switch to DESTDIR install. (diff)
downloadgentoo-2-411430183a2e4a538a99b0c9fa30218919e36db2.tar.gz
gentoo-2-411430183a2e4a538a99b0c9fa30218919e36db2.tar.bz2
gentoo-2-411430183a2e4a538a99b0c9fa30218919e36db2.zip
Add Hardened support #318171
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/gcc-4.5.0.ebuild24
2 files changed, 15 insertions, 14 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 13ec1b1640fa..98d4dd736a41 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.761 2010/06/19 01:53:09 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.762 2010/06/21 22:49:21 zorry Exp $
+
+ 21 Jun 2010; Magnus Granberg <zorry@gentoo.org> gcc-4.5.0.ebuild:
+ Add hardened support #318171
*gcc-4.4.4-r1 (19 Jun 2010)
*gcc-4.4.3-r3 (19 Jun 2010)
diff --git a/sys-devel/gcc/gcc-4.5.0.ebuild b/sys-devel/gcc/gcc-4.5.0.ebuild
index 59cc3dcc4c33..0b66f637f165 100644
--- a/sys-devel/gcc/gcc-4.5.0.ebuild
+++ b/sys-devel/gcc/gcc-4.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.0.ebuild,v 1.6 2010/05/17 20:02:39 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.5.0.ebuild,v 1.7 2010/06/21 22:49:21 zorry Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -8,18 +8,16 @@ UCLIBC_VER="1.0"
ETYPE="gcc-compiler"
# Hardened gcc 4 stuff
-#PIE_VER="10.1.5"
-#SPECS_VER="0.9.4"
-
-# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
-#PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
-#PIE_UCLIBC_STABLE="x86 arm"
-#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
-#SSP_UCLIBC_STABLE=""
-
-# whether we should split out specs files for multiple {PIE,SSP}-by-default
-# and vanilla configurations.
-SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+PIE_VER="0.4.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm
+# uclibc need tls and nptl support for SSP support"
+SSP_UCLIBC_STABLE=""
+#end Hardened stuff
inherit toolchain