summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-07-01 07:27:56 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-07-01 07:27:56 +0000
commit3bc66a35110e834a1ad894d074705c4fb214d06c (patch)
tree6366de129bbe0f07ff24aacf4131e52790a1079b /sys-devel
parentCleaned ebuild, EAPI=4 bump (diff)
downloadgentoo-2-3bc66a35110e834a1ad894d074705c4fb214d06c.tar.gz
gentoo-2-3bc66a35110e834a1ad894d074705c4fb214d06c.tar.bz2
gentoo-2-3bc66a35110e834a1ad894d074705c4fb214d06c.zip
Version bump (bug #373305), fix some repoman warnings.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/gcc-4.3.5.ebuild5
-rw-r--r--sys-devel/gcc/gcc-4.3.6.ebuild80
-rw-r--r--sys-devel/gcc/metadata.xml2
4 files changed, 91 insertions, 4 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index d5a3bd8d6dc9..769a28891d60 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.813 2011/07/01 06:02:29 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.814 2011/07/01 07:27:56 dirtyepic Exp $
+
+*gcc-4.3.6 (01 Jul 2011)
+
+ 01 Jul 2011; Ryan Hill <dirtyepic@gentoo.org> gcc-4.3.5.ebuild,
+ +gcc-4.3.6.ebuild, metadata.xml:
+ Version bump (bug #373305), fix some repoman warnings.
01 Jul 2011; Ryan Hill <dirtyepic@gentoo.org> gcc-4.3.4.ebuild:
4.3.4 p1.3 fixes a race condition in the build system (bug #305739).
diff --git a/sys-devel/gcc/gcc-4.3.5.ebuild b/sys-devel/gcc/gcc-4.3.5.ebuild
index e9ada1e5bcac..9b4853b184d5 100644
--- a/sys-devel/gcc/gcc-4.3.5.ebuild
+++ b/sys-devel/gcc/gcc-4.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.5.ebuild,v 1.5 2011/03/11 07:06:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.5.ebuild,v 1.6 2011/07/01 07:27:56 dirtyepic Exp $
PATCH_VER="1.1"
UCLIBC_VER="1.0"
@@ -23,10 +23,11 @@ SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
inherit toolchain
-DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+DESCRIPTION="The GNU Compiler Collection"
LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ ) FDL-1.2"
KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
RDEPEND=">=sys-libs/zlib-1.1.4
>=sys-devel/gcc-config-1.4
diff --git a/sys-devel/gcc/gcc-4.3.6.ebuild b/sys-devel/gcc/gcc-4.3.6.ebuild
new file mode 100644
index 000000000000..fdd4bf2e0085
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.3.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.6.ebuild,v 1.1 2011/07/01 07:27:56 dirtyepic Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# Hardened gcc 4 stuff
+PIE_VER="10.1.5"
+SPECS_VER="0.9.4"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm sparc"
+PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ ) FDL-1.2"
+KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.3
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ =x11-libs/gtk+-2*
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ sys-devel/flex
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.3.2/gcc-4.3.2-softfloat.patch
+}
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index 9b1f00063244..97774ddaf7d8 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -6,7 +6,7 @@
<flag name="d">Enable support for the D programming language</flag>
<flag name="fixed-point">Enable fixed-point arithmetic support for MIPS targets
in gcc (Warning: significantly increases compile time!)</flag>
- <flag name="go">Build the GCC Go language frontend.</flag>
+ <flag name="go">Build the GCC Go language frontend.</flag>
<flag name="graphite">Add support for the framework for loop
optimizations based on a polyhedral intermediate representation</flag>
<flag name="ip28">Enable building a compiler capable of building a kernel